summaryrefslogtreecommitdiffstats
path: root/testing/lua5.2-stringy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-26 09:08:05 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-26 09:08:05 +0200
commit1937f8699ac517b8817dd2b74db31fd2164b9192 (patch)
treed1e8648c5020b3b7800739b9940f7d22626a591e /testing/lua5.2-stringy
parent604068b806f658e7e28f92c85d06ddbd50138b15 (diff)
downloadaports-1937f8699ac517b8817dd2b74db31fd2164b9192.tar.bz2
aports-1937f8699ac517b8817dd2b74db31fd2164b9192.tar.xz
testing/lua5.2-stringy: fallback got gcc if CC is unset
also use upstream as source rather than own fork
Diffstat (limited to 'testing/lua5.2-stringy')
-rw-r--r--testing/lua5.2-stringy/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/testing/lua5.2-stringy/APKBUILD b/testing/lua5.2-stringy/APKBUILD
index 3a302a11d..0e19d0719 100644
--- a/testing/lua5.2-stringy/APKBUILD
+++ b/testing/lua5.2-stringy/APKBUILD
@@ -3,7 +3,7 @@
_luaver=5.2
pkgname=lua${_luaver}-stringy
pkgver=0.4
-pkgrel=0
+pkgrel=1
pkgdesc="Lua string utility library"
url="https://code.google.com/p/bpbio/downloads/list"
arch="all"
@@ -12,9 +12,9 @@ depends=""
makedepends="lua${_luaver}-dev"
install=""
subpackages=""
-source="lua-stringy-$pkgver.tar.gz::https://github.com/ncopa/lua-stringy/archive/v$pkgver.tar.gz"
+source="lua-projects-$pkgver.tar.gz::https://github.com/brentp/lua-projects/archive/$pkgver.tar.gz"
-_builddir="$srcdir"/lua-stringy-$pkgver/stringy
+_builddir="$srcdir"/lua-projects-$pkgver/stringy
prepare() {
local i
cd "$_builddir"
@@ -27,7 +27,7 @@ prepare() {
build() {
cd "$_builddir"
- make CC="$CC" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" \
+ make CC="${CC:-gcc}" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" \
LUA_PC="lua$_luaver" LUA="lua$_luaver" || return 1
}
@@ -38,6 +38,6 @@ package() {
cp stringy.so "$pkgdir"/$_lualibdir/
}
-md5sums="1c10c3c3bc800f0fb2920257ea884d1e lua-stringy-0.4.tar.gz"
-sha256sums="f953b83c9f4310aae206cb8938d89b2d659020322d2ad0778649ba707052b58b lua-stringy-0.4.tar.gz"
-sha512sums="d2607cd71d9b03bb4a8c91637a36eecebd6279c49ff8c7fdd58c0244ee1c4ccd9e26140aee9886886c7176c58f953300ebef1a2fe1a9f96bedf7e1d1c11135dd lua-stringy-0.4.tar.gz"
+md5sums="cac1787756fe42151d7b60df9f19c9e3 lua-projects-0.4.tar.gz"
+sha256sums="72a800d2e3e1cc13fbf458ad5cbc06b8ea705afedfe72221dbe9e7cec935721e lua-projects-0.4.tar.gz"
+sha512sums="7bcd5449a99e5e1633e9cd1175208f1cde65a8dddbd9a06726c16518805387a5d3809fc7644fae090c4f3e948ed1364911e12d923fc26dbf5378c8adb1a07b3a lua-projects-0.4.tar.gz"