summaryrefslogtreecommitdiffstats
path: root/testing/lua5.2-xctrl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-26 08:09:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-26 08:09:50 +0000
commit2a1a0b3d6c82cdeea3e76ea95476cda94737f16f (patch)
tree3886a3ee5736c8f044a25560c9c8d424fae3d1fe /testing/lua5.2-xctrl
parent07c5a09098741a25dcda197b7819fe76c5232762 (diff)
downloadaports-2a1a0b3d6c82cdeea3e76ea95476cda94737f16f.tar.bz2
aports-2a1a0b3d6c82cdeea3e76ea95476cda94737f16f.tar.xz
testing/lua5.2-xctrl: new aport
Lua 5.2 module to query and manipulate X11 window managers http://code.google.com/p/xctrl/
Diffstat (limited to 'testing/lua5.2-xctrl')
-rw-r--r--testing/lua5.2-xctrl/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/lua5.2-xctrl/APKBUILD b/testing/lua5.2-xctrl/APKBUILD
new file mode 100644
index 000000000..57308e58e
--- /dev/null
+++ b/testing/lua5.2-xctrl/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=lua$_luaver-xctrl
+pkgver=2013.06.20
+_x=${pkgver%%.*}
+_y=${pkgver%.*}
+_y=${_y#*.}
+_z=${pkgver##*.}
+_ver=${_x}-${_y}-${_z}
+pkgrel=0
+pkgdesc="Lua $_luaver module to query and manipulate X11 window managers"
+url="http://code.google.com/p/xctrl/"
+arch="all"
+license="GPL-2"
+depends=
+makedepends="lua$_luaver-dev libx11-dev libxmu-dev libiconv-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://xctrl.googlecode.com/files/xctrl-$_ver.tar.gz"
+
+_builddir="$srcdir"/xctrl-$_ver
+_lua_libdir=/usr/lib/lua/$_luaver
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ export EXTRA_CFLAGS="-fPIC $( pkg-config lua$_luaver --cflags )"
+ [ "$ALPINE_LIBC" != "eglibc" ] && export EXTRA_LDFLAGS="-liconv"
+ make -C src LUA=lua5.2 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/$_lua_libdir "$pkgdir"/usr/share/doc/$pkgname
+ install src/xctrl.so "$pkgdir"/$_lua_libdir/xctrl.so
+ install doc/lxctrl.html "$pkgdir"/usr/share/doc/$pkgname/lxctrl.html
+}
+
+md5sums="789f39228436e4c806911c6cbaae444a xctrl-2013-06-20.tar.gz"
+sha256sums="9089ff10f5396e0a74b3f80c03d8f54395219d72f6ea0084e2858d7195ececbf xctrl-2013-06-20.tar.gz"
+sha512sums="ebfbd3b13c0d5432c71afa6bc70984c794242204c9ce9eaaf391092f7cf5c99dbe0c66335bb9c97413d304f1f77529bddf6a0f37fb10eeab5fbcb7d75dc92d48 xctrl-2013-06-20.tar.gz"