summaryrefslogtreecommitdiffstats
path: root/testing/luajit
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-12-16 12:17:43 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-12-16 12:17:43 +0100
commitd35ff33629e1847b8bf2d58973073225a0db7a50 (patch)
tree90ada934f4d85bd86cc6d4827d967ba6c5ed8bb7 /testing/luajit
parentb081c9fea7d5d66a0cfeadfc9543ddc4751655ce (diff)
downloadaports-d35ff33629e1847b8bf2d58973073225a0db7a50.tar.bz2
aports-d35ff33629e1847b8bf2d58973073225a0db7a50.tar.xz
testing/luajit: upgrade to 2.0.0
- remove unnecessary variables - make pkgdesc more informative - install license file
Diffstat (limited to 'testing/luajit')
-rw-r--r--testing/luajit/APKBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/testing/luajit/APKBUILD b/testing/luajit/APKBUILD
index 7646ed1ba..b01f66bb2 100644
--- a/testing/luajit/APKBUILD
+++ b/testing/luajit/APKBUILD
@@ -1,22 +1,18 @@
-# Contributor: Cameron Banta <cbanta@gmail.com>
# Maintainer: Cameron Banta <cbanta@gmail.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
pkgname=luajit
-_pkgname=LuaJIT
-pkgver=2.0.0_beta8
-_pkgver=${pkgver//_/-}
+pkgver=2.0.0
pkgrel=0
-pkgdesc="Just-In-Time Compiler for the Lua programming language"
-url="http://luajit.org"
+pkgdesc='Just-in-time compiler and replacement for Lua 5.1 '
+url='http://luajit.org'
arch="all"
license="MIT"
-depends=""
-depends_dev=""
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://luajit.org/download/$_pkgname-$_pkgver.tar.gz"
+source="http://luajit.org/download/LuaJIT-$pkgver.tar.gz"
-_builddir=$srcdir/$_pkgname-$_pkgver
+_builddir=$srcdir/LuaJIT-$pkgver
build() {
cd "$_builddir"
@@ -26,7 +22,9 @@ build() {
package() {
cd "$_builddir"
make install DESTDIR="$pkgdir" PREFIX=/usr || return 1
- ln -sf /usr/bin/luajit-${_pkgver} $pkgdir/usr/bin/luajit
+
+ install -Dm644 "$_builddir"/COPYRIGHT \
+ $pkgdir/usr/share/licenses/$pkgname/COPYRIGHT
}
-md5sums="f0748a73ae268d49b1d01f56c4fe3e61 LuaJIT-2.0.0-beta8.tar.gz"
+md5sums="97a2b87cc0490784f54b64cfb3b8f5ad LuaJIT-2.0.0.tar.gz"