summaryrefslogtreecommitdiffstats
path: root/testing/mktorrent
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-10-31 10:23:59 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-10-31 10:23:59 +0000
commita15c2b26811dc1646011e8f9c7168cfced438848 (patch)
tree793dcc419653a7d8e1c893f7915fe41c85fd6215 /testing/mktorrent
parent3f2a8b17c796722e16fd9b5605e3a8465b7ba7d7 (diff)
downloadaports-a15c2b26811dc1646011e8f9c7168cfced438848.tar.bz2
aports-a15c2b26811dc1646011e8f9c7168cfced438848.tar.xz
testing/mktorrent: new aport. Handy tool for creating .torrent files
Diffstat (limited to 'testing/mktorrent')
-rw-r--r--testing/mktorrent/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/mktorrent/APKBUILD b/testing/mktorrent/APKBUILD
new file mode 100644
index 000000000..54d91603d
--- /dev/null
+++ b/testing/mktorrent/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=mktorrent
+pkgver=0.9.9
+pkgrel=0
+pkgdesc="A handy tool for creating .torrent files"
+url="http://borg.uu3.net/~borg/?mktorrent"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="openssl-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://borg.uu3.net/pub/unix/$pkgname/$pkgname-${pkgver}.tgz"
+_builddir="$srcdir"/$pkgname
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 mktorrent $pkgdir/usr/bin/mktorrent-borg
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/mktorrent/LICENSE
+}
+
+md5sums="8bdfa36982446f3ccd8549fedefb7448 mktorrent-0.9.9.tgz"