summaryrefslogtreecommitdiffstats
path: root/testing/netdiscover
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-15 19:58:26 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:17 -0600
commitcfa00b4d2a1e238a73263716e81fc5d1f1f9707d (patch)
tree92a6f3cec1c3656584993c7c1a2a5646af26916b /testing/netdiscover
parentfa2832fc60002c3743e9b9c67e68ecd2638f397e (diff)
downloadaports-cfa00b4d2a1e238a73263716e81fc5d1f1f9707d.tar.bz2
aports-cfa00b4d2a1e238a73263716e81fc5d1f1f9707d.tar.xz
Initial APKBUILD for netdiscover
Package description: Netdiscover is an active/passive address reconnaissance tool, mainly developed for those wireless networks without dhcp server, when you are wardriving. It can be also used on hub/switched networks. Built on top of libnet and libpcap, it can passively detect online hosts, or search for them, by actively sending arp requests, it can also be used to inspect your network arp traffic, or find network addresses using auto scan mode, which will scan for common local networks.
Diffstat (limited to 'testing/netdiscover')
-rw-r--r--testing/netdiscover/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/netdiscover/APKBUILD b/testing/netdiscover/APKBUILD
new file mode 100644
index 000000000..5db0129cf
--- /dev/null
+++ b/testing/netdiscover/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=netdiscover
+pkgver=0.3
+pkgrel=0.beta6
+pkgdesc="A network address discovering tool"
+url="http://nixgeneration.com/~jaime/netdiscover/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="libnet-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/netdiscover/netdiscover-$pkgver-beta6.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver-beta6
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/doc/
+}
+
+md5sums="0919227a91ecaeeb2443cff249417be2 netdiscover-0.3-beta6.tar.gz"