summaryrefslogtreecommitdiffstats
path: root/testing/netsniff-ng
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-03 09:49:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-03 19:08:02 +0000
commit43f91b3d133e6937a3de8372f60733d02f3fa065 (patch)
tree7113b15784c69a120b079cf52a1007d93cba5249 /testing/netsniff-ng
parentb76222085cfb1f09d8e30e962b2fc3afb5af0567 (diff)
downloadaports-43f91b3d133e6937a3de8372f60733d02f3fa065.tar.bz2
aports-43f91b3d133e6937a3de8372f60733d02f3fa065.tar.xz
Initial APKBUILD for netsniff-ng
Package description: The gain of performance is reached by zero-copy mechanisms, so that the kernel does not need to copy packets from kernelspace to userspace and vice versa. For this purpose, the netsniff-ng suite is libpcap independent, but nevertheless supports the pcap file format for capturing, replaying and performing offline-analysis of pcap dumps. Furthermore, we are focussing on building a robust, clean and secure analyzer and utilities that complete netsniff-ng as a support for network development, debugging or network reconnaissance. netsniff-ng consists of much more than only a network analyzer. Next to the zero-copy sniffer itself, further tools like trafgen, a powerful zero-copy network packet generator, or ifpps, a tool that provides top-like kernel networking statistics, are being shipped. Some use cases and features - Open source project and free licensing - Integrated high-performance capabilities - Analizing and debugging of network problems or protocol implementations - Reverse engineering of (i.e. proprietary) network protocols - Dumping, replaying and offline analysis of pcap traces - Focus on usability, robustness, security and functionality - Support utility for penetration testing, network reconnaissance - Network statistic creation (e.g. for Nagios, gnuplot) - Powerful, flexible and performant traffic generation - Reliable, top-like kernel networking statistics
Diffstat (limited to 'testing/netsniff-ng')
-rw-r--r--testing/netsniff-ng/APKBUILD41
-rw-r--r--testing/netsniff-ng/netsniff-ng-unkown.patch14
2 files changed, 55 insertions, 0 deletions
diff --git a/testing/netsniff-ng/APKBUILD b/testing/netsniff-ng/APKBUILD
new file mode 100644
index 000000000..53f4be8b3
--- /dev/null
+++ b/testing/netsniff-ng/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=netsniff-ng
+pkgver=0.5.5.0
+pkgrel=0
+pkgdesc="A network analyzer and networking toolkit"
+url="http://netsniff-ng.org/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.netsniff-ng.org/pub/netsniff-ng/$pkgname-$pkgver.tar.gz
+ netsniff-ng-unkown.patch"
+
+_builddir="$srcdir"/$pkgname
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make -C src || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install -C src || return 1
+}
+
+md5sums="bd303bdeb7244bb1e4e966b94f7671c4 netsniff-ng-0.5.5.0.tar.gz
+e3593dead3b91eb42cef984bae75320b netsniff-ng-unkown.patch"
diff --git a/testing/netsniff-ng/netsniff-ng-unkown.patch b/testing/netsniff-ng/netsniff-ng-unkown.patch
new file mode 100644
index 000000000..14c1ae998
--- /dev/null
+++ b/testing/netsniff-ng/netsniff-ng-unkown.patch
@@ -0,0 +1,14 @@
+--- netsniff-ng/src/Makefile.orig
++++ netsniff-ng/src/Makefile
+@@ -39,9 +39,9 @@
+ @install -D $(target) $(DESTDIR)/$(BINDIR)/$(target)
+ @install -d $(DESTDIR)/$(ETCDIR)/$(target)/rules
+ @cp -r rules/*.bpf $(DESTDIR)/$(ETCDIR)/$(target)/rules/
+- @cat $(MANDIR_LOCAL)/$(target).8 | gzip --best > \
++ @cat $(MANDIR_LOCAL)/$(target).8 | gzip > \
+ $(MANDIR_LOCAL)/$(target).8.gz
+- @install -D $(MANDIR_LOCAL)/$(target).8.gz \
++ @install -Dm644 $(MANDIR_LOCAL)/$(target).8.gz \
+ $(DESTDIR)/$(MANDIR)/$(target).8.gz
+
+ uninstall: