summaryrefslogtreecommitdiffstats
path: root/testing/openlldp
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-07-19 12:15:20 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-07-19 12:15:20 +0000
commit18d9f9af03c9797a0cb68c105b281e52900564fd (patch)
tree1d94f39b779849cc6fe56a870b5ddbe806432a6f /testing/openlldp
parentf35ad3221162020000991bbddb5203227c53778a (diff)
downloadaports-18d9f9af03c9797a0cb68c105b281e52900564fd.tar.bz2
aports-18d9f9af03c9797a0cb68c105b281e52900564fd.tar.xz
testing/openlldp: new aport
Diffstat (limited to 'testing/openlldp')
-rw-r--r--testing/openlldp/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/openlldp/APKBUILD b/testing/openlldp/APKBUILD
new file mode 100644
index 000000000..140ff91d9
--- /dev/null
+++ b/testing/openlldp/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=openlldp
+pkgver=0.4a
+_realver=0.4alpha
+pkgrel=0
+pkgdesc="Open Source implementation of the IEEE standard 802.1AB Link Layer Discovery Protocol (LLDP)"
+url="http://openlldp.sourceforge.net/"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$_realver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="f48ffd632b96246cbf0f5c485dea3b01 openlldp-0.4alpha.tar.gz"