summaryrefslogtreecommitdiffstats
path: root/testing/openlldp
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-10-28 11:12:09 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-10-28 11:12:09 +0000
commitfb990d5ea38fb4a596478e81de3dc5ffaf0319ee (patch)
tree46e92ea60edead7cf59188636205c94e157664df /testing/openlldp
parent589307e7d42fdff22aca545a2c67ff32c27d734c (diff)
downloadaports-fb990d5ea38fb4a596478e81de3dc5ffaf0319ee.tar.bz2
aports-fb990d5ea38fb4a596478e81de3dc5ffaf0319ee.tar.xz
testing/openlldp: init added
Diffstat (limited to 'testing/openlldp')
-rw-r--r--testing/openlldp/APKBUILD16
-rw-r--r--testing/openlldp/openlldp.confd2
-rwxr-xr-xtesting/openlldp/openlldp.initd24
3 files changed, 33 insertions, 9 deletions
diff --git a/testing/openlldp/APKBUILD b/testing/openlldp/APKBUILD
index 140ff91d9..570e66a1b 100644
--- a/testing/openlldp/APKBUILD
+++ b/testing/openlldp/APKBUILD
@@ -2,7 +2,7 @@
pkgname=openlldp
pkgver=0.4a
_realver=0.4alpha
-pkgrel=0
+pkgrel=1
pkgdesc="Open Source implementation of the IEEE standard 802.1AB Link Layer Discovery Protocol (LLDP)"
url="http://openlldp.sourceforge.net/"
license="GPL"
@@ -14,10 +14,10 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz"
_builddir="$srcdir"/$pkgname-$_realver
-prepare() {
- cd "$_builddir"
- # apply patches here
-}
+#prepare() {
+# cd "$_builddir"
+# apply patches here
+#}
build() {
cd "$_builddir"
@@ -31,10 +31,8 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
-
- # remove the 2 lines below (and this) if there is no init.d script
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+ install -m755 -D ../../$pkgname.initd "$pkgdir"/etc/init.d/lldpd
+ install -m644 -D ../../$pkgname.confd "$pkgdir"/etc/conf.d/lldpd
}
md5sums="f48ffd632b96246cbf0f5c485dea3b01 openlldp-0.4alpha.tar.gz"
diff --git a/testing/openlldp/openlldp.confd b/testing/openlldp/openlldp.confd
new file mode 100644
index 000000000..38d961348
--- /dev/null
+++ b/testing/openlldp/openlldp.confd
@@ -0,0 +1,2 @@
+# Remove existing pid file at startup
+OPTS="-s"
diff --git a/testing/openlldp/openlldp.initd b/testing/openlldp/openlldp.initd
new file mode 100755
index 000000000..4ab856add
--- /dev/null
+++ b/testing/openlldp/openlldp.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+
+NAME="lldpd"
+DAEMON="/usr/sbin/$NAME"
+pidfile=/var/run/$NAME.pid
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting ${NAME}"
+ start-stop-daemon --start --quiet --pidfile ${pidfile} \
+ --exec ${DAEMON} -- ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${NAME}"
+ start-stop-daemon --stop --exec ${DAEMON}
+ eend $?
+}
+