summaryrefslogtreecommitdiffstats
path: root/testing/oxygen-gtk
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-05-13 11:12:14 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-05-13 11:12:38 -0500
commit410d8f644de56a9f84a21e15a0c5edeb38f739c9 (patch)
treee9c09603b4cf7923a5255b1c53bc1820060a097b /testing/oxygen-gtk
parentc84e474fb2bb8038d7da16e27e28a5661f36626b (diff)
downloadaports-410d8f644de56a9f84a21e15a0c5edeb38f739c9.tar.bz2
aports-410d8f644de56a9f84a21e15a0c5edeb38f739c9.tar.xz
testing/oxygen-gtk: new aport
Diffstat (limited to 'testing/oxygen-gtk')
-rw-r--r--testing/oxygen-gtk/APKBUILD42
-rw-r--r--testing/oxygen-gtk/isnan.patch20
2 files changed, 62 insertions, 0 deletions
diff --git a/testing/oxygen-gtk/APKBUILD b/testing/oxygen-gtk/APKBUILD
new file mode 100644
index 000000000..58a8fbbd4
--- /dev/null
+++ b/testing/oxygen-gtk/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=oxygen-gtk
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="gtk+ oxygen port"
+url="http://www.kde.org/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="gtk+-dev"
+makedepends="$depends_dev cmake"
+install=""
+subpackages=
+source="http://kde.mirrors.tds.net/pub/kde/stable/oxygen-gtk/$pkgver/src/oxygen-gtk-$pkgver.tar.bz2
+ isnan.patch"
+
+_builddir="$srcdir"/oxygen-gtk-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_SKIP_RPATH=ON "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="4a30da4b5442d896c054cfcae783248e oxygen-gtk-1.0.5.tar.bz2
+7425615ff80fd7afb0b90e6bed613f62 isnan.patch"
diff --git a/testing/oxygen-gtk/isnan.patch b/testing/oxygen-gtk/isnan.patch
new file mode 100644
index 000000000..5e2d27477
--- /dev/null
+++ b/testing/oxygen-gtk/isnan.patch
@@ -0,0 +1,20 @@
+--- oxygen-gtk-1.0.5.orig/src/oxygencolorutils.cpp
++++ oxygen-gtk-1.0.5/src/oxygencolorutils.cpp
+@@ -460,7 +460,7 @@
+ {
+ if( amount <= 0.0 ) return base;
+ if( amount >= 1.0 ) return color;
+- if( isnan( amount ) ) return base;
++ if( __isnan( amount ) ) return base;
+
+ double ri = contrastRatio( base, color );
+ double rg = 1.0 + ( ( ri + 1.0 ) * amount * amount * amount );
+@@ -487,7 +487,7 @@
+ {
+ if( bias <= 0.0 ) return c1;
+ if( bias >= 1.0 ) return c2;
+- if( isnan( bias ) ) return c1;
++ if( __isnan( bias ) ) return c1;
+
+ double r = mixdouble( c1.red(), c2.red(), bias );
+ double g = mixdouble( c1.green(), c2.green(), bias );