summaryrefslogtreecommitdiffstats
path: root/testing/pastebinc
diff options
context:
space:
mode:
authorJeremy Thomerson <jeremy@thomersonfamily.com>2011-07-28 23:33:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-31 10:36:36 +0000
commita4f82851d78f8c444d8f7ad7dde9791f8da1f23c (patch)
treed46eba96399d38b1b0fcfaddf9fd6b0078173e6c /testing/pastebinc
parent25c9a4fea3291f14b611c36b05d730aa77280f8b (diff)
downloadaports-a4f82851d78f8c444d8f7ad7dde9791f8da1f23c.tar.bz2
aports-a4f82851d78f8c444d8f7ad7dde9791f8da1f23c.tar.xz
testing/pastebinc: new aport
a new aport for my new project: pastebinc see https://github.com/jthomerson/pastebinc for more info
Diffstat (limited to 'testing/pastebinc')
-rw-r--r--testing/pastebinc/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/pastebinc/APKBUILD b/testing/pastebinc/APKBUILD
new file mode 100644
index 000000000..d40962f0b
--- /dev/null
+++ b/testing/pastebinc/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
+# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
+pkgname=pastebinc
+pkgver=0.9
+pkgrel=0
+pkgdesc="utility to pipe data into a paste on pastebin.com or a similar site"
+url="https://github.com/jthomerson/pastebinc"
+arch="all"
+license="ASL 2.0"
+depends=
+depends_dev=
+makedepends="wget glib-dev curl-dev"
+install=""
+subpackages=""
+source="saveas-https://github.com/jthomerson/pastebinc/tarball/RELEASE_0.9-BETA/$pkgname-$pkgver-$pkgrel.tar.gz"
+_builddir="$srcdir/jthomerson-pastebinc-8dbb86b"
+
+makeparams="VERSION=$pkgver-$pkgrel CONFDIR=/etc/pastebinc"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make $makeparams clean || return 1
+ make $makeparams || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make $makeparams DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="a1620a9d04ecb79f42ede3768987567a pastebinc-0.9-0.tar.gz"