summaryrefslogtreecommitdiffstats
path: root/testing/perl-class-load
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2013-09-04 08:47:13 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2013-09-04 09:04:44 +0000
commit08abeeaa611b9d71bbb81b984c2fee96dca1f782 (patch)
treeb502d0e0420098a3790c9bbee8f5c0ab9618e48f /testing/perl-class-load
parented5c2b22d6c7121b64f06ffce199563bd9b13121 (diff)
downloadaports-08abeeaa611b9d71bbb81b984c2fee96dca1f782.tar.bz2
aports-08abeeaa611b9d71bbb81b984c2fee96dca1f782.tar.xz
testing/perl-class-load: new aport
Diffstat (limited to 'testing/perl-class-load')
-rw-r--r--testing/perl-class-load/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/perl-class-load/APKBUILD b/testing/perl-class-load/APKBUILD
new file mode 100644
index 000000000..4e40f568f
--- /dev/null
+++ b/testing/perl-class-load/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-class-load
+_pkgreal=Class-Load
+pkgver=0.20
+pkgrel=0
+pkgdesc="a working (require "Class::Name") and more"
+url="http://search.cpan.org/dist/Class-Load/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-module-runtime perl-module-implementation perl-package-stash perl-data-optlist perl-try-tiny"
+cpanmakedepends="perl-test-requires perl-test-fatal perl-test-requires perl-test-fatal perl-test-without-module"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="9ccb131338a6cf1318599c08c095cf72 Class-Load-0.20.tar.gz"
+sha256sums="823c45885e1d29feef6867282b881d402f42af6413c7e0e9f8fe32086aee8c20 Class-Load-0.20.tar.gz"
+sha512sums="e208a3c6fc01b8ad33dbdac29eb9d11914686822bb607fbdf0eaeb6ea375a8c77bd85e85b6eaced2aff1c8f0424033b428a42a1f2b2c4fb4eeefe38a8d0abe48 Class-Load-0.20.tar.gz"