summaryrefslogtreecommitdiffstats
path: root/testing/perl-class-weaksingleton
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-10-29 09:13:52 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-10-29 09:13:52 +0000
commit43b76775ab226c278aac49d05b783d22cdfbaf4d (patch)
tree30228ae8c89405cb018357cdc7636d1f9d49422a /testing/perl-class-weaksingleton
parentdba456218add36beff202430a4ee6e9b6a38c020 (diff)
downloadaports-43b76775ab226c278aac49d05b783d22cdfbaf4d.tar.bz2
aports-43b76775ab226c278aac49d05b783d22cdfbaf4d.tar.xz
testing/perl-class-weaksingleton: new aport
Diffstat (limited to 'testing/perl-class-weaksingleton')
-rw-r--r--testing/perl-class-weaksingleton/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-class-weaksingleton/APKBUILD b/testing/perl-class-weaksingleton/APKBUILD
new file mode 100644
index 000000000..ba894a896
--- /dev/null
+++ b/testing/perl-class-weaksingleton/APKBUILD
@@ -0,0 +1,39 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-class-weaksingleton
+_pkgreal=Class-WeakSingleton
+pkgver=1.05
+pkgrel=0
+pkgdesc="A Singleton that expires when all the references to it expire"
+url="http://search.cpan.org/dist/Class-WeakSingleton/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/J/JJ/JJORE/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="58caaec9d9d360eb641bfb1db5cdec82 Class-WeakSingleton-1.05.tar.gz"