summaryrefslogtreecommitdiffstats
path: root/testing/perl-extutils-installpaths
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-20 08:48:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-20 10:27:33 +0000
commit663614537923823f1362d20a5abf047ecf89828e (patch)
tree64c528282490e86b5ac628ba42752edc7fc54096 /testing/perl-extutils-installpaths
parent3b5d125a603ecb143f9b5c0c64d76e465f8fbcab (diff)
downloadaports-663614537923823f1362d20a5abf047ecf89828e.tar.bz2
aports-663614537923823f1362d20a5abf047ecf89828e.tar.xz
testing/perl-extutils-installpaths: new aport
Build.PL install path logic made easy http://search.cpan.org/dist/ExtUtils-InstallPaths/
Diffstat (limited to 'testing/perl-extutils-installpaths')
-rw-r--r--testing/perl-extutils-installpaths/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/perl-extutils-installpaths/APKBUILD b/testing/perl-extutils-installpaths/APKBUILD
new file mode 100644
index 000000000..2fd95ce25
--- /dev/null
+++ b/testing/perl-extutils-installpaths/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-extutils-installpaths
+_pkgreal=ExtUtils-InstallPaths
+pkgver=0.010
+pkgrel=0
+pkgdesc="Build.PL install path logic made easy"
+url="http://search.cpan.org/dist/ExtUtils-InstallPaths/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-extutils-config"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="f0b00cc6c04653588a6298fa1f16c07f ExtUtils-InstallPaths-0.010.tar.gz"
+sha256sums="d14cbff118e467900c2c488b55b83ef697d6eb1b8f592c0521f1d82848bf2156 ExtUtils-InstallPaths-0.010.tar.gz"
+sha512sums="3639e8e05b2d59d1a5c4548d74e51158ce6e6b2260d2958f5500b7bb2f64470b72b8b9690e3ec917ff6db8baf0a81038178336bccbc272116e16b520cac73f0f ExtUtils-InstallPaths-0.010.tar.gz"