summaryrefslogtreecommitdiffstats
path: root/testing/perl-extutils-pkgconfig
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-11-26 21:39:22 -0500
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-12-04 22:09:37 -0500
commit8a3ef049a1fce2dea83ff44faaf0c82db0191cde (patch)
treea5dc7c48eeabfd861acdfb94a1b4730e5fde4c23 /testing/perl-extutils-pkgconfig
parent0727f73c57b390c8eee90276afbf3d5a9045fb12 (diff)
downloadaports-8a3ef049a1fce2dea83ff44faaf0c82db0191cde.tar.bz2
aports-8a3ef049a1fce2dea83ff44faaf0c82db0191cde.tar.xz
testing/perl-extutils-pkgconfig: new APKBUILD
Diffstat (limited to 'testing/perl-extutils-pkgconfig')
-rw-r--r--testing/perl-extutils-pkgconfig/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-extutils-pkgconfig/APKBUILD b/testing/perl-extutils-pkgconfig/APKBUILD
new file mode 100644
index 000000000..03bc080e2
--- /dev/null
+++ b/testing/perl-extutils-pkgconfig/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-extutils-pkgconfig
+_pkgreal=ExtUtils-PkgConfig
+pkgver=1.12
+pkgrel=0
+pkgdesc="unknown"
+url="http://search.cpan.org/dist/ExtUtils-PkgConfig/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/T/TS/TSCH/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="8fc5c0b30cfda2048ec87ae418cc3508 ExtUtils-PkgConfig-1.12.tar.gz"