summaryrefslogtreecommitdiffstats
path: root/testing/perl-local-lib
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-07-01 23:50:30 -0400
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-07-01 23:51:11 -0400
commitadda09f4e25df7fab2b18302a28d96815bfc962c (patch)
treefd45ae70ee318e1aa9b25f7bc94bf752139ff6c9 /testing/perl-local-lib
parent1299f9d6624bca1ec8758c3e2823688a8308276a (diff)
downloadaports-adda09f4e25df7fab2b18302a28d96815bfc962c.tar.bz2
aports-adda09f4e25df7fab2b18302a28d96815bfc962c.tar.xz
testing/perl-local-lib: new aport
Diffstat (limited to 'testing/perl-local-lib')
-rw-r--r--testing/perl-local-lib/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-local-lib/APKBUILD b/testing/perl-local-lib/APKBUILD
new file mode 100644
index 000000000..96b27e279
--- /dev/null
+++ b/testing/perl-local-lib/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-local-lib
+_pkgreal=local-lib
+pkgver=1.008004
+pkgrel=0
+pkgdesc="create and use a local lib/ for perl modules with PERL5LIB"
+url="http://search.cpan.org/dist/local-lib/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AP/APEIRON/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="6244fa9d77e818594acbaf572aece326 local-lib-1.008004.tar.gz"