summaryrefslogtreecommitdiffstats
path: root/testing/perl-module-runtime
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2013-09-04 08:52:39 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2013-09-04 09:04:46 +0000
commit829d0e1e92ad25bf865de80d2e97666c8a586fe1 (patch)
tree3e9a39002a364f553ca30e6a293c1fcfcf1876cd /testing/perl-module-runtime
parent3564a236d6ab025e895577931589f603d8354bd1 (diff)
downloadaports-829d0e1e92ad25bf865de80d2e97666c8a586fe1.tar.bz2
aports-829d0e1e92ad25bf865de80d2e97666c8a586fe1.tar.xz
testing/perl-module-runtime: new aport
Diffstat (limited to 'testing/perl-module-runtime')
-rw-r--r--testing/perl-module-runtime/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/perl-module-runtime/APKBUILD b/testing/perl-module-runtime/APKBUILD
new file mode 100644
index 000000000..96112ec92
--- /dev/null
+++ b/testing/perl-module-runtime/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-module-runtime
+_pkgreal=Module-Runtime
+pkgver=0.013
+pkgrel=0
+pkgdesc="runtime module handling"
+url="http://search.cpan.org/dist/Module-Runtime/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-test-pod perl-test-pod-coverage"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/Z/ZE/ZEFRAM/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="62b88b1f5f0e975a5d7c80cd46167b97 Module-Runtime-0.013.tar.gz"
+sha256sums="ec37e03d90dc905679dab62a82f42cf0897ed79244b87fd9d531438dc3c31023 Module-Runtime-0.013.tar.gz"
+sha512sums="4e8ad61d27d9e269a26a7da4905fcfb2bcc4d775ca1bcddd96f14e8238c725ff8c916dfc8e6faebad5d42c3a0a8eb7d264298471b0cc65d972b5d344a6b9a339 Module-Runtime-0.013.tar.gz"