summaryrefslogtreecommitdiffstats
path: root/testing/perl-pod-cpandoc
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-10-29 12:29:03 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-10-29 12:29:03 +0000
commita8a94d8abcad82ad9fd328bad3347cd3e4b70eea (patch)
tree76a1b51bdc925a206658b37e215605108e3a4292 /testing/perl-pod-cpandoc
parent9d9427affcfa9028724a872107eeaae23a99daa0 (diff)
downloadaports-a8a94d8abcad82ad9fd328bad3347cd3e4b70eea.tar.bz2
aports-a8a94d8abcad82ad9fd328bad3347cd3e4b70eea.tar.xz
testing/perl-pod-cpandoc: new aport
Diffstat (limited to 'testing/perl-pod-cpandoc')
-rw-r--r--testing/perl-pod-cpandoc/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-pod-cpandoc/APKBUILD b/testing/perl-pod-cpandoc/APKBUILD
new file mode 100644
index 000000000..eec86f3af
--- /dev/null
+++ b/testing/perl-pod-cpandoc/APKBUILD
@@ -0,0 +1,39 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-pod-cpandoc
+_pkgreal=Pod-Cpandoc
+pkgver=0.12
+pkgrel=0
+pkgdesc="perldoc that works for modules you don't have installed"
+url="http://search.cpan.org/dist/Pod-Cpandoc/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/S/SA/SARTAK/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="f170a7700b74ba0bad696debb3211416 Pod-Cpandoc-0.12.tar.gz"