summaryrefslogtreecommitdiffstats
path: root/testing/perl-rt-authen-externalauth
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2013-08-01 14:58:09 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2013-08-01 14:58:09 +0000
commitd29a66e06d0cf83c9f3f3e01d8b4cf15f1b0d6a6 (patch)
treefb5800e2034ba10464869438a62d4d5519c5df51 /testing/perl-rt-authen-externalauth
parentb6fd6a62542fc140d5d957f2e1820e1a06e6d5cf (diff)
downloadaports-d29a66e06d0cf83c9f3f3e01d8b4cf15f1b0d6a6.tar.bz2
aports-d29a66e06d0cf83c9f3f3e01d8b4cf15f1b0d6a6.tar.xz
testing/perl-rt-authen-externalauth: new aport
External authenticator for RT
Diffstat (limited to 'testing/perl-rt-authen-externalauth')
-rw-r--r--testing/perl-rt-authen-externalauth/APKBUILD52
-rw-r--r--testing/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch19
-rw-r--r--testing/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch21
3 files changed, 92 insertions, 0 deletions
diff --git a/testing/perl-rt-authen-externalauth/APKBUILD b/testing/perl-rt-authen-externalauth/APKBUILD
new file mode 100644
index 000000000..0b5770b53
--- /dev/null
+++ b/testing/perl-rt-authen-externalauth/APKBUILD
@@ -0,0 +1,52 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=perl-rt-authen-externalauth
+_realname=RT-Authen-ExternalAuth
+pkgver=0.17
+pkgrel=0
+pkgdesc="RT Authentication using External Sources"
+url="http://search.cpan.org/~tsibley"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends rt4 perl-dbi perl-ldap perl-net-ssleay"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/${_realname}-${pkgver}.tar.gz
+ use-DESTDIR-perl-rt-authen-externalauth.patch
+ dont-install-in-local-perl-rt-authen-externalauth.patch
+ "
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ patch -p1 < ../use-DESTDIR-perl-rt-authen-externalauth.patch || return 1
+ patch -p1 < ../dont-install-in-local-perl-rt-authen-externalauth.patch || return 1
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor DESTDIR="$pkgdir" \
+ RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4"
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make DESTDIR="$pkgdir" RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4" && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="f1d17f4c83d7ec2615db2e42f7b82d19 RT-Authen-ExternalAuth-0.17.tar.gz
+6e2fa78c896de4f10b3f4a3030dd8659 use-DESTDIR-perl-rt-authen-externalauth.patch
+fd061d4a9be350959daacc2576eb7282 dont-install-in-local-perl-rt-authen-externalauth.patch"
+sha256sums="cd12c0c223c4cd4588feb5de76eb234ab62c6cbc865f3f82249f0023c21f5aca RT-Authen-ExternalAuth-0.17.tar.gz
+6b254295f06fca929ebe96fdcd08d8f1c9fbae0ffaf9e1a9cd83ce57572f5bdc use-DESTDIR-perl-rt-authen-externalauth.patch
+7f1f659858905d9aae817957279255c883d36f12fd8c85271a1fb37b5301e9de dont-install-in-local-perl-rt-authen-externalauth.patch"
+sha512sums="5110f21c46887049f0a43772cbc3d22bd24b29140a5753572dd3e29a75597bd3aaebb32dc73fb82482d98e321a1473cc2b8929b8d921702ef52adf08cb3ec85f RT-Authen-ExternalAuth-0.17.tar.gz
+880d36550d7272595407b032c5d08da32a949255c1cb772df5c19150b75be599023d5d263fbbc679531751ec878d2dfe6023c4e271738d11446a21cdb1434eed use-DESTDIR-perl-rt-authen-externalauth.patch
+2df06b5519854c313c38c430cae5bd5c76c2cc3b878bda8cf202d40e9ba816166317e1d73a2cdb982ef5390ce4801fa8c6888d225a5f235828b4350042dbefcf dont-install-in-local-perl-rt-authen-externalauth.patch"
diff --git a/testing/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch b/testing/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch
new file mode 100644
index 000000000..418ba7bb8
--- /dev/null
+++ b/testing/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch
@@ -0,0 +1,19 @@
+Author: Tom Jampen <tom@cryptography.ch>
+Description: Fix plugin path to use debian's request-tracker plugin directory.
+
+diff -Naurp a/inc/Module/Install/RTx.pm b/inc/Module/Install/RTx.pm
+--- a/inc/Module/Install/RTx.pm 2012-05-10 16:22:06.166168825 +0200
++++ b/inc/Module/Install/RTx.pm 2012-06-11 12:51:31.879609814 +0200
+@@ -38,8 +38,9 @@ sub RTx {
+ @ARGV = grep { /PREFIX=(.*)/ ? ( ( $prefix = $1 ), 0 ) : 1 } @ARGV;
+
+ if ($prefix) {
+- $RT::LocalPath = $prefix;
+- $INC{'RT.pm'} = "$RT::LocalPath/lib/RT.pm";
++ push @INC, "$prefix";
++ require RT;
++ $RT::LocalPluginPath = '$(DESTDIR)'."$prefix/plugins";
+ } else {
+ local @INC = (
+ $ENV{RTHOME} ? ( $ENV{RTHOME}, "$ENV{RTHOME}/lib" ) : (),
+
diff --git a/testing/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch b/testing/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch
new file mode 100644
index 000000000..88a90876d
--- /dev/null
+++ b/testing/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch
@@ -0,0 +1,21 @@
+diff --git a/inc/Module/Install/RTx.pm b/inc/Module/Install/RTx.pm
+index 20a354b..7e681c6 100755
+--- a/inc/Module/Install/RTx.pm
++++ b/inc/Module/Install/RTx.pm
+@@ -83,13 +83,13 @@ sub RTx {
+ if ( $RT::LocalPluginPath ) {
+ die "Because of bugs in RT 3.8.0 this extension can not be installed.\n"
+ ."Upgrade to RT 3.8.1 or newer.\n" if $RT::VERSION =~ /^3\.8\.0/;
+- $path{$_} = $RT::LocalPluginPath . "/$original_name/$_"
++ $path{$_} = '$(DESTDIR)' . $RT::LocalPluginPath . "/$original_name/$_"
+ foreach @DIRS;
+ } else {
+ foreach ( @DIRS ) {
+ no strict 'refs';
+ my $varname = "RT::Local" . ucfirst($_) . "Path";
+- $path{$_} = ${$varname} || "$RT::LocalPath/$_";
++ $path{$_} = '$(DESTDIR)' . (${$varname} || "$RT::LocalPath/$_");
+ }
+
+ $path{$_} .= "/$name" for grep $path{$_}, qw(etc po var);
+