summaryrefslogtreecommitdiffstats
path: root/testing/perl-strictures
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2012-02-23 16:39:03 -0500
committerKiyoshi Aman <aphrael@alpinelinux.org>2012-02-23 16:39:46 -0500
commit7eb1acf12160b84c17c431ad84d8c878618363ff (patch)
tree33f66486d224742c042371333b213872bad623e7 /testing/perl-strictures
parent9f376bd28c5e4e84067fb6f79c8b286f15ed9194 (diff)
downloadaports-7eb1acf12160b84c17c431ad84d8c878618363ff.tar.bz2
aports-7eb1acf12160b84c17c431ad84d8c878618363ff.tar.xz
testing/perl-strictures: new APKBUILD
Diffstat (limited to 'testing/perl-strictures')
-rw-r--r--testing/perl-strictures/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/testing/perl-strictures/APKBUILD b/testing/perl-strictures/APKBUILD
index 4e4b3a449..dfc692c23 100644
--- a/testing/perl-strictures/APKBUILD
+++ b/testing/perl-strictures/APKBUILD
@@ -1,6 +1,6 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=perl-strictures
_pkgreal=strictures
pkgver=1.002002
@@ -10,7 +10,7 @@ url="http://search.cpan.org/dist/strictures/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=""
+cpanmakedepends=" "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
@@ -20,11 +20,13 @@ _builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
make && make test
}