summaryrefslogtreecommitdiffstats
path: root/testing/perl-test-without-module
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2013-09-04 09:01:13 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2013-09-04 09:04:48 +0000
commit9c9d2287b64f69c69dbd6604432d7f477e879440 (patch)
tree6e5fb82efb4a72c3b1f456ecc1e1887f8b4720a9 /testing/perl-test-without-module
parent1c6c4f23b486d68627e26860d815cb8349205483 (diff)
downloadaports-9c9d2287b64f69c69dbd6604432d7f477e879440.tar.bz2
aports-9c9d2287b64f69c69dbd6604432d7f477e879440.tar.xz
testing/perl-test-without-module: new aport
Diffstat (limited to 'testing/perl-test-without-module')
-rw-r--r--testing/perl-test-without-module/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/perl-test-without-module/APKBUILD b/testing/perl-test-without-module/APKBUILD
new file mode 100644
index 000000000..27c6d6d94
--- /dev/null
+++ b/testing/perl-test-without-module/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-test-without-module
+_pkgreal=Test-Without-Module
+pkgver=0.17
+pkgrel=0
+pkgdesc="Test fallback behaviour in absence of modules"
+url="http://search.cpan.org/dist/Test-Without-Module/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev perl-test-pod perl-file-slurp $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/C/CO/CORION/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="4480ece707cb6bbedaae8fbe41320927 Test-Without-Module-0.17.tar.gz"
+sha256sums="a691b0bf6d92dedbacfd547551021389ebc79c51937de2b914e792457da56ff7 Test-Without-Module-0.17.tar.gz"
+sha512sums="66d0a164c72ce70cf996e8700c54e442613a18113bd87210b344a38778704b665c9efffd321616993eabac77ee13496e5bd2145c41cf1cb5b134e72252632526 Test-Without-Module-0.17.tar.gz"