summaryrefslogtreecommitdiffstats
path: root/testing/php-zmq
diff options
context:
space:
mode:
authorV.Krishn <vkrishn4@gmail.com>2013-04-22 08:31:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-07 13:32:08 +0000
commit9d83d67dd339b8a23057551b3b03cb6e530f1153 (patch)
tree75cbb6049067c6355842b4f77a7436721a675a72 /testing/php-zmq
parentcfe9a6f9c029a252ce365acd3d6c765a03fe09fb (diff)
downloadaports-9d83d67dd339b8a23057551b3b03cb6e530f1153.tar.bz2
aports-9d83d67dd339b8a23057551b3b03cb6e530f1153.tar.xz
testing/php-zmq: new aport
Initial APKBUILD file of php-zmq PHP bindings for 0MQ (ZeroMQ). https://github.com/mkoppanen/php-zmq
Diffstat (limited to 'testing/php-zmq')
-rw-r--r--testing/php-zmq/APKBUILD32
-rw-r--r--testing/php-zmq/zmq.ini2
2 files changed, 34 insertions, 0 deletions
diff --git a/testing/php-zmq/APKBUILD b/testing/php-zmq/APKBUILD
new file mode 100644
index 000000000..01aa3a52f
--- /dev/null
+++ b/testing/php-zmq/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: V.Krishn <vkrishn4@gmail.com>
+# Maintainer:
+pkgname=php-zmq
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="ZeroMQ for PHP"
+url="https://github.com/mkoppanen/php-zmq"
+arch="all"
+license="PHP"
+depends="php libzmq"
+makedepends="php-dev autoconf zeromq-dev"
+subpackages=""
+source="saveas-https://github.com/mkoppanen/php-zmq/archive/1.0.5.tar.gz/$pkgname-$pkgver.tar.gz
+zmq.ini"
+_builddir="$srcdir/php-zmq-$pkgver"
+
+build() {
+ cd "$_builddir"
+ phpize || return 1
+ ./configure --enable-zmq \
+ --with-php-config=/usr/bin/php-config
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT=$pkgdir install || return 1
+ install -D -m644 "$srcdir"/zmq.ini "$pkgdir"/etc/php/conf.d/zmq.ini
+}
+
+md5sums="06e36323b8af330b7aa137cbc3cbe6a4 php-zmq-1.0.5.tar.gz
+976eb10e2fb904e342ed3036fb3fc433 zmq.ini"
diff --git a/testing/php-zmq/zmq.ini b/testing/php-zmq/zmq.ini
new file mode 100644
index 000000000..da8d25f61
--- /dev/null
+++ b/testing/php-zmq/zmq.ini
@@ -0,0 +1,2 @@
+;[zmq]
+;extension=zmq.so