summaryrefslogtreecommitdiffstats
path: root/testing/podofo
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-06-20 12:00:47 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-06-20 12:02:01 +0000
commit9c6e16bb228787c35137e4a5576a5085a9788a10 (patch)
treefee729147f5d9c0ee9189dfad821042b129668cd /testing/podofo
parent6a3353563b226569a73920d63a1ef672043b21b5 (diff)
downloadaports-9c6e16bb228787c35137e4a5576a5085a9788a10.tar.bz2
aports-9c6e16bb228787c35137e4a5576a5085a9788a10.tar.xz
testing/chmlib podofo py-dateutils py-importlib py-pycountry py-qt py-sip : new aports
Diffstat (limited to 'testing/podofo')
-rw-r--r--testing/podofo/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/podofo/APKBUILD b/testing/podofo/APKBUILD
new file mode 100644
index 000000000..1b413ebf1
--- /dev/null
+++ b/testing/podofo/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=podofo
+pkgver=0.9.1
+pkgrel=0
+pkgdesc="A C++ library to work with the PDF file format"
+url="http://podofo.sourceforge.net"
+arch="all"
+license="GPL"
+depends=
+depends_dev="tiff-dev libpng-dev fontconfig-dev cmake"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .. \
+ -DPODOFO_BUILD_SHARED=1 \
+ -DPODOFO_HAVE_JPEG_LIB=1 \
+ -DPODOFO_HAVE_PNG_LIB=1 \
+ -DPODOFO_HAVE_TIFF_LIB=1
+ make || return 1
+}
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="cec586ab69f92bc88d38b5d4b8eee5a0 podofo-0.9.1.tar.gz"