summaryrefslogtreecommitdiffstats
path: root/testing/pwbunny
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-12-10 23:44:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 14:47:41 +0000
commitec37eb3045e3874296ab5f9c154e29dc4c158c84 (patch)
tree13b6d9eab4b2d002cbcc8deb4bad855533ba7ec4 /testing/pwbunny
parentb12e6b85fc987bd362cb21ae2d2dec5fd16c2953 (diff)
downloadaports-ec37eb3045e3874296ab5f9c154e29dc4c158c84.tar.bz2
aports-ec37eb3045e3874296ab5f9c154e29dc4c158c84.tar.xz
Inital APKBUILD for pwbunny
Package description: Pwbunny is a password manager: it stores and retrieves passwords in an encrypted file. This allows you to choose unique randomly generated passwords for every service you use. Website: http://code.google.com/p/pwbunny/
Diffstat (limited to 'testing/pwbunny')
-rw-r--r--testing/pwbunny/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/pwbunny/APKBUILD b/testing/pwbunny/APKBUILD
new file mode 100644
index 000000000..eed911210
--- /dev/null
+++ b/testing/pwbunny/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=pwbunny
+pkgver=1.1
+pkgrel=0
+pkgdesc="A password manager that stores and retrieves passwords in an encrypted file"
+url="http://code.google.com/p/pwbunny/"
+arch="noarch"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir" || return 1
+}
+
+md5sums="07d1145eef28670cd634cf4231bd7508 pwbunny-1.1.tar.gz"