summaryrefslogtreecommitdiffstats
path: root/testing/py-argh
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-05 15:48:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:14 +0000
commit973c8bf485dfc592d2ad7e3b9f837a60fd960d5e (patch)
treecf08f6fd804606ff26ad563d7b8ff6c40d44e7a7 /testing/py-argh
parent1c5a64b1877d5f6f067258f962d7ca1c7871ecfe (diff)
downloadaports-973c8bf485dfc592d2ad7e3b9f837a60fd960d5e.tar.bz2
aports-973c8bf485dfc592d2ad7e3b9f837a60fd960d5e.tar.xz
testing/py-argh: new aport
A Python argparse wrapper http://github.com/neithere/argh/
Diffstat (limited to 'testing/py-argh')
-rw-r--r--testing/py-argh/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-argh/APKBUILD b/testing/py-argh/APKBUILD
new file mode 100644
index 000000000..84694c884
--- /dev/null
+++ b/testing/py-argh/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-argh
+_pkgname=argh
+pkgver=0.23.3
+pkgrel=0
+pkgdesc="A Python argparse wrapper"
+url="http://github.com/neithere/argh/"
+arch="noarch"
+license="LGPL3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="25bb02c6552b42875f2c36714e0ff16c argh-0.23.3.tar.gz"
+sha256sums="076f27ed25f64339186810075c9eb2aa5121bd330851d42639abde17a9b9774b argh-0.23.3.tar.gz"
+sha512sums="e177cfe1a4c29133cb2543031b81c5927650dc56c8d6d90a3e1777a6f1e9db4d49dca90a0bbb21228f2c797beaa9a83acc5ee426556cc8037301a429e526690f argh-0.23.3.tar.gz"