summaryrefslogtreecommitdiffstats
path: root/testing/py-bottle-websocket
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-05 13:07:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:14 +0000
commitce5a440534ddecedc60d901e0215d19603840eb9 (patch)
tree6d2c3c10cd54a7cc571591a302bc4909b94878e1 /testing/py-bottle-websocket
parent00c04a9efdd11a152831385921f9b2a194b6c6f7 (diff)
downloadaports-ce5a440534ddecedc60d901e0215d19603840eb9.tar.bz2
aports-ce5a440534ddecedc60d901e0215d19603840eb9.tar.xz
testing/py-bottle-websocket: new aport
Bottle WebSockets plugin https://pypi.python.org/pypi/bottle-websocket
Diffstat (limited to 'testing/py-bottle-websocket')
-rw-r--r--testing/py-bottle-websocket/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-websocket/APKBUILD b/testing/py-bottle-websocket/APKBUILD
new file mode 100644
index 000000000..5435edea7
--- /dev/null
+++ b/testing/py-bottle-websocket/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-websocket
+_pkgname=bottle-websocket
+pkgver=0.2.5
+pkgrel=0
+pkgdesc="Bottle websocket plugin"
+url="https://pypi.python.org/pypi/bottle-websocket"
+arch="noarch"
+license="MIT"
+depends="python py-bottle"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="2a13170819b4818b0ba306c95ea563ee bottle-websocket-0.2.5.tar.gz"
+sha256sums="9c83ce0a04309db3a90b64694e470946d9d39f3ae23927761a5ecbbd7e9d0b08 bottle-websocket-0.2.5.tar.gz"
+sha512sums="3760cc2450678a1e0bfd5a7b9850a1699f931643db4ddaa30193c0e39245920da4cd5b56704c391953514bb9370759fc457dc75c73e9800742817b5feaf82af2 bottle-websocket-0.2.5.tar.gz"