summaryrefslogtreecommitdiffstats
path: root/testing/py-exconsole
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-07 07:22:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:16 +0000
commitda5f4f64f9df83555525d1f22fe0f7b13e7820a1 (patch)
treeb4a0f7842ba284c93b7cfc38473e6ec97e727452 /testing/py-exconsole
parent40d0effa426ca3be9e7e02a158364d527c0be7b0 (diff)
downloadaports-da5f4f64f9df83555525d1f22fe0f7b13e7820a1.tar.bz2
aports-da5f4f64f9df83555525d1f22fe0f7b13e7820a1.tar.xz
testing/py-exconsole: new aport
Emergency/postmortem Python console https://github.com/Eugeny/exconsole
Diffstat (limited to 'testing/py-exconsole')
-rw-r--r--testing/py-exconsole/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-exconsole/APKBUILD b/testing/py-exconsole/APKBUILD
new file mode 100644
index 000000000..c1de9a442
--- /dev/null
+++ b/testing/py-exconsole/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-exconsole
+_pkgname=python-exconsole
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="Emergency/postmortem Python console"
+url="https://github.com/Eugeny/exconsole"
+arch="noarch"
+license="LGPL3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b1d54a66d0f816ab4e87204d839e6b9e python-exconsole-0.1.4.tar.gz"
+sha256sums="9b4bd4f2ecab33bf6729151bee1ce474588f0afeacc0ab36f236922249da765b python-exconsole-0.1.4.tar.gz"
+sha512sums="6f79a55044212982a9cb5eb8692e68c9730c71f6978a30a636f3793ee86bf787fa385a1c8668ed55ce81af5d14ea30450eea7971c32cb8cccac93226afbb84ae python-exconsole-0.1.4.tar.gz"