summaryrefslogtreecommitdiffstats
path: root/testing/py-flask-peewee
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 12:59:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:31 +0000
commit3c88d48fedeb734bba83e4b97938d582f9dfbd73 (patch)
tree7196742cd46e9144f154a7c8bae108e0e23309db /testing/py-flask-peewee
parentb6dcd1b0cb9f8647a337ce48b47adfc35974604f (diff)
downloadaports-3c88d48fedeb734bba83e4b97938d582f9dfbd73.tar.bz2
aports-3c88d48fedeb734bba83e4b97938d582f9dfbd73.tar.xz
testing/py-flask-peewee: new aport
Flask integration for peewee http://pypi.python.org/pypi/flask-peewee
Diffstat (limited to 'testing/py-flask-peewee')
-rw-r--r--testing/py-flask-peewee/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-peewee/APKBUILD b/testing/py-flask-peewee/APKBUILD
new file mode 100644
index 000000000..d92ac69f5
--- /dev/null
+++ b/testing/py-flask-peewee/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-peewee
+_pkgname=flask-peewee
+pkgver=0.6.5
+pkgrel=0
+pkgdesc="Flask integration for peewee"
+url="http://pypi.python.org/pypi/flask-peewee"
+arch="noarch"
+license="MIT"
+depends="python py-flask py-peewee"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6f3af829967026c0e20b5e34dbde2426 flask-peewee-0.6.5.tar.gz"
+sha256sums="7b39fac44b86e057a44fc059193e444cefbf3aa7807ba3022fa090ac50ce89c2 flask-peewee-0.6.5.tar.gz"
+sha512sums="4e1f01d78d1c778cd95a784920d8cfbddc712b8224d93cd0dfe566ee007b781dc4b353bb27c4240475234660363b2b77093d504bf5ef90f358e116f8373020d5 flask-peewee-0.6.5.tar.gz"