summaryrefslogtreecommitdiffstats
path: root/testing/py-flask-rst
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 09:44:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:27 +0000
commit0de03340478f9ac8d45f71c3c0d540ff35478abe (patch)
tree2473fda30c71d1230e580a17deee39b1d81d3bcb /testing/py-flask-rst
parent02f479f3b2fc229698a98043086b6a0bc093312e (diff)
downloadaports-0de03340478f9ac8d45f71c3c0d540ff35478abe.tar.bz2
aports-0de03340478f9ac8d45f71c3c0d540ff35478abe.tar.xz
testing/py-flask-rst: new aport
Flask rst extension https://pypi.python.org/pypi/flask-rst
Diffstat (limited to 'testing/py-flask-rst')
-rw-r--r--testing/py-flask-rst/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-rst/APKBUILD b/testing/py-flask-rst/APKBUILD
new file mode 100644
index 000000000..b0ababb47
--- /dev/null
+++ b/testing/py-flask-rst/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-rst
+_pkgname=flask-rst
+pkgver=0.1
+pkgrel=0
+pkgdesc="Flask rst extension"
+url="https://pypi.python.org/pypi/flask-rst"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="7ebb0e9d4e6dac6e7112b6645e5f6be3 flask-rst-0.1.tar.gz"
+sha256sums="ef710c55fbcae41cd661be3aa7c0ede66365835b2106b175b4c66051d59fb377 flask-rst-0.1.tar.gz"
+sha512sums="3a1401c7987c02a96e37ee0f61dd6901422170503f8735937972e0e7afb3c3769cbce34fab6003b657a429ec843f4c505c6a3ac42b24454743fac17deddebe4e flask-rst-0.1.tar.gz"