summaryrefslogtreecommitdiffstats
path: root/testing/py-html5lib
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-15 18:41:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:33 +0000
commit86640b6b6524c0f5f2bf40ace87799855a65bbc7 (patch)
tree4e22f4c1de930f5149fe8edd6ae4c157fc20621e /testing/py-html5lib
parent1796e763314a5fe4b44b7889212eabe9ff05cc22 (diff)
downloadaports-86640b6b6524c0f5f2bf40ace87799855a65bbc7.tar.bz2
aports-86640b6b6524c0f5f2bf40ace87799855a65bbc7.tar.xz
testing/py-html5lib: new aport
A Python HTML parser https://github.com/html5lib/html5lib-python
Diffstat (limited to 'testing/py-html5lib')
-rw-r--r--testing/py-html5lib/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-html5lib/APKBUILD b/testing/py-html5lib/APKBUILD
new file mode 100644
index 000000000..852a1ae94
--- /dev/null
+++ b/testing/py-html5lib/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-html5lib
+_pkgname=html5lib
+pkgver=0.99
+pkgrel=0
+pkgdesc="A Python HTML parser"
+url="https://github.com/html5lib/html5lib-python"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b7d837eac0f572736f7753cabaab16ce html5lib-0.99.tar.gz"
+sha256sums="aff6fd3031c563883197e5a04b7df324086ff5f358278a0386808c463a077e59 html5lib-0.99.tar.gz"
+sha512sums="3076ed2003f174e0800db60fe86ac37106ec8f797759b497d48978767c04565b1ff3fa7f00ed8f504bba1247aeba546400e9c612f2c0a4b032c4b93b1b4de164 html5lib-0.99.tar.gz"