summaryrefslogtreecommitdiffstats
path: root/testing/py-httreplay
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-29 10:31:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-30 08:23:20 +0000
commitad00295ffd69caede973ba3f68253f7a1aa83a45 (patch)
tree7f1ee2975760bcd8203495de18324cf3abe251bf /testing/py-httreplay
parentb68dedee7a1978b51f0f6a178529a358d54a58e1 (diff)
downloadaports-ad00295ffd69caede973ba3f68253f7a1aa83a45.tar.bz2
aports-ad00295ffd69caede973ba3f68253f7a1aa83a45.tar.xz
testing/py-httreplay: new aport
A HTTP replay library for testing http://github.com/davepeck/httreplay
Diffstat (limited to 'testing/py-httreplay')
-rw-r--r--testing/py-httreplay/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-httreplay/APKBUILD b/testing/py-httreplay/APKBUILD
new file mode 100644
index 000000000..b4dd01a88
--- /dev/null
+++ b/testing/py-httreplay/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-httreplay
+_pkgname=httreplay
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="A HTTP replay library for testing"
+url="http://github.com/davepeck/httreplay"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="7da38f272e87e6af8843739d8372a3ba httreplay-0.1.4.tar.gz"
+sha256sums="f332c95f3c84f6867e32a61031386bead99ad378416bdef383a12c98346d66df httreplay-0.1.4.tar.gz"
+sha512sums="fee65b6c32f761bf9f22cf70162f279f5d9af33ba58f3d52902dba58d87326007485def11f4e0fae230d5abe3c043958cbc98734410a5b801ae2bff9261eda98 httreplay-0.1.4.tar.gz"