summaryrefslogtreecommitdiffstats
path: root/testing/py-hurry-filesize
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-07 09:58:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:16 +0000
commitea7fe89b235be31b58ddf5c8903e2618d3be33b0 (patch)
treeb983017c64bf90d242e64065ed0875a349322c3a /testing/py-hurry-filesize
parent6ad960b467bc2bf6c1d24114a75d339ece2a6889 (diff)
downloadaports-ea7fe89b235be31b58ddf5c8903e2618d3be33b0.tar.bz2
aports-ea7fe89b235be31b58ddf5c8903e2618d3be33b0.tar.xz
testing/py-hurry-filesize: new aport
A Python library for human readable file sizes https://pypi.python.org/pypi/hurry.filesize
Diffstat (limited to 'testing/py-hurry-filesize')
-rw-r--r--testing/py-hurry-filesize/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-hurry-filesize/APKBUILD b/testing/py-hurry-filesize/APKBUILD
new file mode 100644
index 000000000..a2fb6f9c6
--- /dev/null
+++ b/testing/py-hurry-filesize/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-hurry-filesize
+_pkgname=hurry.filesize
+pkgver=0.9
+pkgrel=0
+pkgdesc="A Python library for human readable file sizes"
+url="https://pypi.python.org/pypi/hurry.filesize"
+arch="noarch"
+license="ZPL 2.1"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8549ccd09bb31b5ff1e8e8c1eacc7794 hurry.filesize-0.9.tar.gz"
+sha256sums="f5368329adbef86accd3bc9490522340bb79260455ae89b1a42c10f63801b9a6 hurry.filesize-0.9.tar.gz"
+sha512sums="24b7ebf5a6e833cec01d1904e5202ab5bde238fbeabb92d893866118e152c0f861f853e11bb71c58d84060bffaf0b7bc88221e37aaacc0b07751febf8a2b1606 hurry.filesize-0.9.tar.gz"