summaryrefslogtreecommitdiffstats
path: root/testing/py-logilab-astng
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-14 21:12:35 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commitcdba06ba0b38e4a0515d016e252180a97914772d (patch)
tree09ebc0ac0b3468d48604e850f17b926a92cf82b8 /testing/py-logilab-astng
parent56298d54f76bbc8233324edf3bbf7954c70c53a6 (diff)
downloadaports-cdba06ba0b38e4a0515d016e252180a97914772d.tar.bz2
aports-cdba06ba0b38e4a0515d016e252180a97914772d.tar.xz
Initial APKBUILD for py-logilab-astng
Package description: The aim of this module is to provide a common base representation of python source code for projects such as pychecker, pyreverse, pylint... Well, actually the development of this library is essentialy governed by pylint's needs.
Diffstat (limited to 'testing/py-logilab-astng')
-rw-r--r--testing/py-logilab-astng/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py-logilab-astng/APKBUILD b/testing/py-logilab-astng/APKBUILD
new file mode 100644
index 000000000..0a8a78882
--- /dev/null
+++ b/testing/py-logilab-astng/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-logilab-astng
+_realname=logilab-astng
+pkgver=0.21.1
+pkgrel=0
+pkgdesc="Rebuild a new abstract syntax tree from Python's ast"
+url="http://pypi.python.org/pypi/logilab-astng"
+arch="noarch"
+license="GPL2+"
+depends="python py-logilab-common"
+depends_dev=""
+makedepends="python-dev py-logilab-common"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/l/"$_realname"/"$_realname"-$pkgver.tar.gz"
+_builddir="$srcdir"/"$_realname"-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ rm -f "$pkgdir"/usr/lib/python2.?/site-packages/logilab/__init__.*
+}
+
+md5sums="f25dd1d92a1b80d07a2f9d5bb4fe9d97 logilab-astng-0.21.1.tar.gz"