summaryrefslogtreecommitdiffstats
path: root/testing/py-ludibrio
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-15 19:31:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:34 +0000
commitf84e049b23719ac6f037269bebcc26dad63c8e2a (patch)
tree21cbc79417bf0bed12a0c3b05c450c495b7a7a43 /testing/py-ludibrio
parent46cd4fef21410ec2b200f13c20f81ab416012814 (diff)
downloadaports-f84e049b23719ac6f037269bebcc26dad63c8e2a.tar.bz2
aports-f84e049b23719ac6f037269bebcc26dad63c8e2a.tar.xz
testing/py-ludibrio: new aport
A Platform for test doubles in Python https://github.com/nsigustavo/ludibrio
Diffstat (limited to 'testing/py-ludibrio')
-rw-r--r--testing/py-ludibrio/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-ludibrio/APKBUILD b/testing/py-ludibrio/APKBUILD
new file mode 100644
index 000000000..e99b271aa
--- /dev/null
+++ b/testing/py-ludibrio/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-ludibrio
+_pkgname=ludibrio
+pkgver=3.1.0
+pkgrel=0
+pkgdesc="A Platform for test doubles in Python"
+url="https://github.com/nsigustavo/ludibrio"
+arch="noarch"
+license="GPL"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="d83f752b7cad8baa9c6b6aa92605cab3 ludibrio-3.1.0.tar.gz"
+sha256sums="271a2a866b00a059d9330dc1213d182731121c83088a42f6b3e7f24777b522db ludibrio-3.1.0.tar.gz"
+sha512sums="7a29f30761ef376960131a04f5b6321a548a29bde0f95087bc6c7138ef50f93d1fb2ac34e8aef7bfa3d4bf852cf07e0edda5f25d3e1d53e8c9359ba4f4e65580 ludibrio-3.1.0.tar.gz"