summaryrefslogtreecommitdiffstats
path: root/testing/py-mongo
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 13:38:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:31 +0000
commitf0d88aa85c97d7e0fbe8ebc5571f11e237ef7c8d (patch)
tree5faed95ddc1d4f586956a87b326c76cf0e2868c5 /testing/py-mongo
parentdec34beae20bbc96137c53492ef9dcfd89ddf337 (diff)
downloadaports-f0d88aa85c97d7e0fbe8ebc5571f11e237ef7c8d.tar.bz2
aports-f0d88aa85c97d7e0fbe8ebc5571f11e237ef7c8d.tar.xz
testing/py-mongo: new aport
A Python driver for MongoDB https://github.com/mongodb/mongo-python-driver
Diffstat (limited to 'testing/py-mongo')
-rw-r--r--testing/py-mongo/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-mongo/APKBUILD b/testing/py-mongo/APKBUILD
new file mode 100644
index 000000000..c361e4752
--- /dev/null
+++ b/testing/py-mongo/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-mongo
+_pkgname=pymongo
+pkgver=2.6.2
+pkgrel=0
+pkgdesc="A Python driver for MongoDB"
+url="https://github.com/mongodb/mongo-python-driver"
+arch="all"
+license="ASL 2.0"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="fd2d8f12055d4a133fe480ec7f20fa94 python-stdnum-0.8.1.tar.gz"
+sha256sums="41bac7de44ac84bc23325070e931e187fb00bfb6b93e0f4fbecc8736bd31b1d2 python-stdnum-0.8.1.tar.gz"
+sha512sums="c3aa3179b6c27ca88ad8a39c086f8305d3406f79e29ea06656c1a5caf2c78a0fac4fa04bb663bb83f2c8e105cf156e9e421854b9b4c16b2cc18825c4f0ae1028 python-stdnum-0.8.1.tar.gz"