summaryrefslogtreecommitdiffstats
path: root/testing/py-pip
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-01-30 03:26:10 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-17 13:33:56 +0000
commitf938273063f559ddc9e42875c10643a55c0b7b63 (patch)
tree8d572dbc1025aa534d6e5773c21d2ce09a22fb99 /testing/py-pip
parented4b275fe1dcefd3a8d817dcdff879e1a27ef21e (diff)
downloadaports-f938273063f559ddc9e42875c10643a55c0b7b63.tar.bz2
aports-f938273063f559ddc9e42875c10643a55c0b7b63.tar.xz
testing/py-pip: new aport
pip is a tool for installing and managing Python packages, such as those found in the Python Package Index. pip is a replacement for easy_install. It mostly uses the same techniques for finding packages, so packages that are easy_installable should be pip-installable as well. This means that you can use pip install SomePackage instead of easy_install SomePackage. http://www.pip-installer.org
Diffstat (limited to 'testing/py-pip')
-rw-r--r--testing/py-pip/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py-pip/APKBUILD b/testing/py-pip/APKBUILD
new file mode 100644
index 000000000..18386c58f
--- /dev/null
+++ b/testing/py-pip/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pip
+_pkgname=pip
+pkgver=1.0
+pkgrel=0
+pkgdesc="A tool for installing and managing Python packages"
+url="http://www.pip-installer.org"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="327fc4a03df189506966e15021730550 pip-1.0.tar.gz"