summaryrefslogtreecommitdiffstats
path: root/testing/py-reconfigure
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-06 22:16:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:16 +0000
commit629a7bb9685257e3b1f28005d806df31fc5f9f1c (patch)
treec242a25573d677f0c87a694e0cd2916178a76e01 /testing/py-reconfigure
parent11349d541e943f684d93748af26991a0f1ea4356 (diff)
downloadaports-629a7bb9685257e3b1f28005d806df31fc5f9f1c.tar.bz2
aports-629a7bb9685257e3b1f28005d806df31fc5f9f1c.tar.xz
testing/py-reconfigure: new aport
A Python library for parsing and generation configuration file formats https://github.com/Eugeny/reconfigure
Diffstat (limited to 'testing/py-reconfigure')
-rw-r--r--testing/py-reconfigure/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-reconfigure/APKBUILD b/testing/py-reconfigure/APKBUILD
new file mode 100644
index 000000000..349326703
--- /dev/null
+++ b/testing/py-reconfigure/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-reconfigure
+_pkgname=reconfigure
+pkgver=0.1.33
+pkgrel=0
+pkgdesc="A Python library for parsing and generation configuration file formats"
+url="https://github.com/Eugeny/reconfigure"
+arch="noarch"
+license="LGPL3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="$_pkgname-$pkgver.tar.gz::https://github.com/Eugeny/reconfigure/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b3ce28ceac3641e43a95f32c365af9a8 reconfigure-0.1.33.tar.gz"
+sha256sums="c8ac576d2351fef9b664ceb03ede8a582b49f42e62dde0fdefc2e4c745b1953f reconfigure-0.1.33.tar.gz"
+sha512sums="d259b1033374ad14d94efea77361c1a3d242f88ec2e1e6728fa5df4dc4c69cdedc9cec4c2031bf6e120f1be92d5d91f985bb6933700dce1cb3bdd9dc3df03508 reconfigure-0.1.33.tar.gz"