summaryrefslogtreecommitdiffstats
path: root/testing/py-setuptools-pep8
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-06 21:40:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:16 +0000
commitdba7f7e43cc405543826c2500dbb3bd585e3f08e (patch)
treeebf847035d2b2037bbe0dd24b49c1c63bba505b3 /testing/py-setuptools-pep8
parentacc5cf277a26e44b314fd8f7c88bca0949f32b8a (diff)
downloadaports-dba7f7e43cc405543826c2500dbb3bd585e3f08e.tar.bz2
aports-dba7f7e43cc405543826c2500dbb3bd585e3f08e.tar.xz
testing/py-setuptools-pep8: new aport
Setuptools plugin for pep8 https://github.com/CraigJPerry/setuptools-pep8
Diffstat (limited to 'testing/py-setuptools-pep8')
-rw-r--r--testing/py-setuptools-pep8/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-setuptools-pep8/APKBUILD b/testing/py-setuptools-pep8/APKBUILD
new file mode 100644
index 000000000..9d13e7a9d
--- /dev/null
+++ b/testing/py-setuptools-pep8/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-setuptools-pep8
+_pkgname=setuptools-pep8
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="Setuptools plugin for pep8"
+url="https://github.com/CraigJPerry/setuptools-pep8"
+arch="noarch"
+license="BSD"
+depends="python py-pep8"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4afdca526e4f7573749dc7af834fad17 setuptools-pep8-0.1.3.tar.gz"
+sha256sums="9126a4bbb3cf4caf724a833d86e7c437aa161fc7568991a46a94e04173c2e18c setuptools-pep8-0.1.3.tar.gz"
+sha512sums="cfa0e17f502bc0dcf43cf696f95468053715ad1789c54762ae64ed73805e22fec6e6675848e90b75eba6d96dfff42a671cb560e16abb9d85753966694fa127fc setuptools-pep8-0.1.3.tar.gz"