summaryrefslogtreecommitdiffstats
path: root/testing/py-sphinx-theme-epfl
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-17 18:32:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:53 +0000
commit8a39c228690a1269730a6310a771270c07c95a11 (patch)
tree736ca47cfbdbfc4f7f74c9b2aff3247ecf4ce228 /testing/py-sphinx-theme-epfl
parente85e9d304e17e14c59a2c361c47914a61f6ae05f (diff)
downloadaports-8a39c228690a1269730a6310a771270c07c95a11.tar.bz2
aports-8a39c228690a1269730a6310a771270c07c95a11.tar.xz
testing/py-sphinx-theme-epfl: new aport
The EPFL Sphinx theme http://kis-doc.epfl.ch/sphinx/
Diffstat (limited to 'testing/py-sphinx-theme-epfl')
-rw-r--r--testing/py-sphinx-theme-epfl/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinx-theme-epfl/APKBUILD b/testing/py-sphinx-theme-epfl/APKBUILD
new file mode 100644
index 000000000..2d960c6a4
--- /dev/null
+++ b/testing/py-sphinx-theme-epfl/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinx-theme-epfl
+_pkgname=epfl-sphinx-theme
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="The EPFL Sphinx theme"
+url="http://kis-doc.epfl.ch/sphinx/"
+arch="noarch"
+license="GPL3"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5d6d32f2757695b7671f71c6ca58cccd epfl-sphinx-theme-1.1.1.tar.gz"
+sha256sums="fa734959c14dd406f6a79ccfe85edb3f8bf203713d761e911bd00c2c46e11fcf epfl-sphinx-theme-1.1.1.tar.gz"
+sha512sums="af36469cbd33c5f8d1a4ebef201838a26dc52c04b1432b6cc49b46bfb74c585aad83da11cc9ebb675ad166573af41b00bed3e4ec770dcd60330599a732196ea0 epfl-sphinx-theme-1.1.1.tar.gz"