summaryrefslogtreecommitdiffstats
path: root/testing/py-sphinx-theme-simple
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-17 18:14:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:53 +0000
commit2d1d39bb1be4d1e2e6ac8f64c2f507e81259f234 (patch)
tree8a4b8ea39ddd76dce3247432a501f9d634ef4564 /testing/py-sphinx-theme-simple
parent4994adaebf1eefb5474d8d9620bd9eb443b7190e (diff)
downloadaports-2d1d39bb1be4d1e2e6ac8f64c2f507e81259f234.tar.bz2
aports-2d1d39bb1be4d1e2e6ac8f64c2f507e81259f234.tar.xz
testing/py-sphinx-theme-simple: new aport
The Simple Sphinx theme https://pypi.python.org/pypi/sphinxtheme-simple
Diffstat (limited to 'testing/py-sphinx-theme-simple')
-rw-r--r--testing/py-sphinx-theme-simple/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinx-theme-simple/APKBUILD b/testing/py-sphinx-theme-simple/APKBUILD
new file mode 100644
index 000000000..7d6230fd7
--- /dev/null
+++ b/testing/py-sphinx-theme-simple/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinx-theme-simple
+_pkgname=sphinxtheme-simple
+pkgver=0.1
+pkgrel=0
+pkgdesc="The Simple Sphinx theme"
+url="https://pypi.python.org/pypi/sphinxtheme-simple"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="030155ef433c645640d1d51818a7da91 sphinxtheme-simple-0.1.tar.gz"
+sha256sums="91c4d9ed9e6e6892b6765cf98780f3ab6d1890abe48d6cba8d0c90561f1fb6f1 sphinxtheme-simple-0.1.tar.gz"
+sha512sums="86d5fbd6e8e98d8a5448240e9925fbe1ffb7de7c2b8c84893b2f8e8c8e23699e35cbf4ddaf6852741f99c690c44551108b8115ca49127d99393d813b6d637e76 sphinxtheme-simple-0.1.tar.gz"