summaryrefslogtreecommitdiffstats
path: root/testing/py-twisted
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-22 21:57:58 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-25 19:36:32 +0000
commite59e3a94bb2bf04539a70c829710c36ca0b51f1a (patch)
tree393a4eae0ab7c03e9880c6052ebf0577a729a787 /testing/py-twisted
parent472f22263f5613910e7c8808d0accd1481a66f57 (diff)
downloadaports-e59e3a94bb2bf04539a70c829710c36ca0b51f1a.tar.bz2
aports-e59e3a94bb2bf04539a70c829710c36ca0b51f1a.tar.xz
testing/py-twisted: upgrade to 12.0.0
Diffstat (limited to 'testing/py-twisted')
-rw-r--r--testing/py-twisted/APKBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/testing/py-twisted/APKBUILD b/testing/py-twisted/APKBUILD
index f1bbbb101..e8c18293c 100644
--- a/testing/py-twisted/APKBUILD
+++ b/testing/py-twisted/APKBUILD
@@ -1,23 +1,33 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-twisted
-pkgver=10.0.0
+_pkgname=Twisted
+pkgver=12.0.0
pkgrel=1
pkgdesc="Asynchronous networking framework written in Python."
url="http://twistedmatrix.com/"
arch="all"
license="MIT"
-depends="python py-crypto py-zope-interface"
+depends="py-crypto py-zope-interface"
makedepends="python-dev"
-source="http://tmrc.mit.edu/mirror/twisted/Twisted/${pkgver%.*}/Twisted-$pkgver.tar.bz2"
+install=""
+subpackages="$pkgname-doc"
+source="http://twistedmatrix.com/Releases/Core/${pkgver%.*}/"$_pkgname"Core-$pkgver.tar.bz2"
+_builddir="$srcdir"/"$_pkgname"Core-$pkgver
build() {
- cd "$srcdir"/Twisted-$pkgver
+ cd "$_builddir"
python setup.py build || return 1
}
package() {
- cd "$srcdir"/Twisted-$pkgver
+ cd "$_builddir"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ _mans="manhole.1 pyhtmlizer.1 tap2deb.1 tapconvert.1 trial.1 twistd.1"
+ for _man in $_mans; do
+ install -m644 -D "$_builddir"/doc/man/$_man \
+ "$pkgdir"/usr/share/man/man1/$_man || return 1
+ done
}
-md5sums="3b226af1a19b25e3b3e93cc6edf5e284 Twisted-10.0.0.tar.bz2"
+
+md5sums="d231ae966799eedaab4c62e062e227e0 TwistedCore-12.0.0.tar.bz2"