summaryrefslogtreecommitdiffstats
path: root/testing/py-tz/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-24 19:41:36 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 14:07:37 +0000
commit97493c03a881c5cdbe841d9bc81820631bcad4de (patch)
treea3f5bfcbf1f1b67d6fb00d236e678151c2ba56e5 /testing/py-tz/APKBUILD
parent78db7c5562738e8376f7763dd9f45e96da33410c (diff)
downloadaports-97493c03a881c5cdbe841d9bc81820631bcad4de.tar.bz2
aports-97493c03a881c5cdbe841d9bc81820631bcad4de.tar.xz
testing/py-tz: new aport
A Python definitions of world timezone http://pytz.sourceforge.net/
Diffstat (limited to 'testing/py-tz/APKBUILD')
-rw-r--r--testing/py-tz/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-tz/APKBUILD b/testing/py-tz/APKBUILD
new file mode 100644
index 000000000..49ba74730
--- /dev/null
+++ b/testing/py-tz/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-tz
+_pkgname=pytz
+pkgver=2013d
+pkgrel=0
+pkgdesc="A Python definitions of world timezone"
+url="http://pytz.sourceforge.net/"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="ee090b586c792bcf393c84dd0a75c9b5 pytz-2013d.tar.gz"
+sha256sums="4eee447b2102141dfc7d92b0536608616f152811a8adee2f120460f368ecc4c6 pytz-2013d.tar.gz"
+sha512sums="c046b9837a1a7b836c4798f9680caa78ef297cd5364a644525336542943001d13ccfab0a41377f346d3e3957628d593730c46f43a148081248ad67213ff3da1c pytz-2013d.tar.gz"