summaryrefslogtreecommitdiffstats
path: root/testing/py-webcolors
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-10 07:19:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:25 +0000
commit710ea5b0c94757c723f5b358053c7ed8308d3662 (patch)
treef66e2fea7f1ce8ebe784ed67565438e2355f7152 /testing/py-webcolors
parent110569cd91f1444ef84ae7757273214540dfba1d (diff)
downloadaports-710ea5b0c94757c723f5b358053c7ed8308d3662.tar.bz2
aports-710ea5b0c94757c723f5b358053c7ed8308d3662.tar.xz
testing/py-webcolors: new aport
A library for working with color names and color value formats https://bitbucket.org/ubernostrum/webcolors
Diffstat (limited to 'testing/py-webcolors')
-rw-r--r--testing/py-webcolors/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-webcolors/APKBUILD b/testing/py-webcolors/APKBUILD
new file mode 100644
index 000000000..e285bbdeb
--- /dev/null
+++ b/testing/py-webcolors/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-webcolors
+_pkgname=webcolors
+pkgver=1.4
+pkgrel=0
+pkgdesc="A library for working with color names and color value formats"
+url="http://blockdiag.com"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="35de9d785b5c04a9cc66a2eae0519254 webcolors-1.4.tar.gz"
+sha256sums="304fc95dab2848c7bf64f378356766e692c2f8b4a8b15fa3509544e6412936e8 webcolors-1.4.tar.gz"
+sha512sums="c31932c7fb0dba22239737d1f01a78c3942619e00d65339f0af61a3546bb6163efdfc648c9766c7c04b09e67f4e23ebb0182488fcf65474f940358cde47aa8e0 webcolors-1.4.tar.gz"