summaryrefslogtreecommitdiffstats
path: root/testing/py-wifi
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-28 09:23:38 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 14:07:40 +0000
commit7a401cbcebc1e8fd5cefb07802472cb2e1d08093 (patch)
tree5b57adf85dee26b53e8a5503f01d9a15c024025c /testing/py-wifi
parentcebc9d77f7a9d744e596bfd995730df84b44a2aa (diff)
downloadaports-7a401cbcebc1e8fd5cefb07802472cb2e1d08093.tar.bz2
aports-7a401cbcebc1e8fd5cefb07802472cb2e1d08093.tar.xz
testing/py-wifi: new aport
Command line tool and library wrappers for network interfaces https://pypi.python.org/pypi/wifi
Diffstat (limited to 'testing/py-wifi')
-rw-r--r--testing/py-wifi/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-wifi/APKBUILD b/testing/py-wifi/APKBUILD
new file mode 100644
index 000000000..5a4b8becf
--- /dev/null
+++ b/testing/py-wifi/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-wifi
+_pkgname=wifi
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Command line tool and library wrappers for network interfaces"
+url="https://pypi.python.org/pypi/wifi"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="7df58691eb39be009e78e0c96b2c5598 wifi-0.2.0.tar.gz"
+sha256sums="d7c482e7ef93cc6ccce312ece095866242038401fb1b717717369f384c6aa1e0 wifi-0.2.0.tar.gz"
+sha512sums="916144686e8cb4338a1f9e0c17375a6258ebc8c1a553911c50ec69c9ba1b465d2f6aac9aced4e4fabf16a08e7c6729af159de4c5e0783e4967cdff17ad01824f wifi-0.2.0.tar.gz"