summaryrefslogtreecommitdiffstats
path: root/testing/python3
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-11 11:07:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-11 11:07:16 +0000
commit4172a700fb692abf6ec69eb708f53c5f6d9281ce (patch)
tree3a442fac5c524b406b482c95342d9370c51289bb /testing/python3
parent1fea062b09726293547136ea292615980adb5a12 (diff)
downloadaports-4172a700fb692abf6ec69eb708f53c5f6d9281ce.tar.bz2
aports-4172a700fb692abf6ec69eb708f53c5f6d9281ce.tar.xz
testing/python3: upgrade to 3.3.4
Diffstat (limited to 'testing/python3')
-rw-r--r--testing/python3/APKBUILD23
-rw-r--r--testing/python3/posix_close.patch20
2 files changed, 38 insertions, 5 deletions
diff --git a/testing/python3/APKBUILD b/testing/python3/APKBUILD
index 5e6b472e9..3dae913a4 100644
--- a/testing/python3/APKBUILD
+++ b/testing/python3/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=python3
-pkgver=3.3.3
+pkgver=3.3.4
_pkgver=3.3
pkgrel=0
pkgdesc="A high-level scripting language"
@@ -11,9 +11,19 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-tests"
depends=""
makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev
sqlite-dev libffi-dev tcl-dev"
-source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz"
+source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
+ posix_close.patch"
_builddir="$srcdir"/Python-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
./configure \
@@ -52,6 +62,9 @@ tests() {
_mv_files
}
-md5sums="4ca001c5586eb0744e3174bc75c6fba8 Python-3.3.3.tar.xz"
-sha256sums="339275b30a1a3fef1589016bf6302c14e870f7a6fd2522bf87a6c2c6d383c685 Python-3.3.3.tar.xz"
-sha512sums="6acd905d2ae70a259de1d502c90ce9cc831b03cd32930d55bdce1f6dd4b2657c4bb8698e46f6558253338046c43ee842befa2d62e35eeb82b82659acbe6ea0aa Python-3.3.3.tar.xz"
+md5sums="8fb961a20600aafafd249537af3ac637 Python-3.3.4.tar.xz
+9f3d2782d046ca2b65647d20a6c6daa4 posix_close.patch"
+sha256sums="c6cc126d91c04e0348882cfbd36d7a844d4e50acc37a3f6a64d67764e3995689 Python-3.3.4.tar.xz
+eb7830dde7db3a906e31053ddaa6145c6ba9f3766b4272722ba5ee7cf9722aff posix_close.patch"
+sha512sums="b6cf2cb32504020c691d5be092ee62415b3f1c1a72ca8285b9f1d8e0770ac57f0d8c451a1e6ab921b77f1abe507c4afd75189b01a3f15438c2e4a4c074c0675a Python-3.3.4.tar.xz
+99791b872f5dd2bb5287fc10a95fcfbdcc40db380e88f88bd8254504950fb3393808a07388cf150f4f09c8e229be15612b3a4c7e707b29e659ae3bf144e51a9d posix_close.patch"
diff --git a/testing/python3/posix_close.patch b/testing/python3/posix_close.patch
new file mode 100644
index 000000000..43133c48d
--- /dev/null
+++ b/testing/python3/posix_close.patch
@@ -0,0 +1,20 @@
+--- ./Modules/posixmodule.c.orig
++++ ./Modules/posixmodule.c
+@@ -7846,7 +7846,7 @@
+ Close a file descriptor (for low level IO).");
+
+ static PyObject *
+-posix_close(PyObject *self, PyObject *args)
++_posix_close(PyObject *self, PyObject *args)
+ {
+ int fd, res;
+ if (!PyArg_ParseTuple(args, "i:close", &fd))
+@@ -11262,7 +11262,7 @@
+ {"open", (PyCFunction)posix_open,\
+ METH_VARARGS | METH_KEYWORDS,
+ posix_open__doc__},
+- {"close", posix_close, METH_VARARGS, posix_close__doc__},
++ {"close", _posix_close, METH_VARARGS, posix_close__doc__},
+ {"closerange", posix_closerange, METH_VARARGS, posix_closerange__doc__},
+ {"device_encoding", device_encoding, METH_VARARGS, device_encoding__doc__},
+ {"dup", posix_dup, METH_VARARGS, posix_dup__doc__},