summaryrefslogtreecommitdiffstats
path: root/testing/python3
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-03-03 16:38:33 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-03-04 09:50:16 +0000
commit791dadbd5c16f4c1a39ac7408d20fe7e87693ada (patch)
tree754869868adaf7ef035199ac6ad20fde5acd49ba /testing/python3
parentc1d38008b366037df8e0bae57a63e5e75571256e (diff)
downloadaports-791dadbd5c16f4c1a39ac7408d20fe7e87693ada.tar.bz2
aports-791dadbd5c16f4c1a39ac7408d20fe7e87693ada.tar.xz
testing/python3: upgrade to 3.3.0
Diffstat (limited to 'testing/python3')
-rw-r--r--testing/python3/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/testing/python3/APKBUILD b/testing/python3/APKBUILD
index 6df07c306..8f435ef96 100644
--- a/testing/python3/APKBUILD
+++ b/testing/python3/APKBUILD
@@ -1,36 +1,37 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=python3
-pkgver=3.2.3
-_pkgver=3.2
+pkgver=3.3.0
+_pkgver=3.3
pkgrel=0
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
license="custom"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tests"
-depends=
+depends=""
makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev
- sqlite-dev libffi-dev tcl-dev"
-source="http://www.python.org/ftp/python/$_pkgver/Python-$_pkgver.tar.bz2"
+ sqlite-dev libffi-dev tcl-dev"
+source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz"
-_builddir="$srcdir"/Python-$_pkgver
+_builddir="$srcdir"/Python-$pkgver
build() {
cd "$_builddir"
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
--enable-shared \
--with-threads \
--with-system-ffi \
--enable-unicode=ucs4 \
--with-dbmliborder=ndbm \
+ --disable-rpath \
|| return 1
-
make || return 1
}
package() {
cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install
- mv "$pkgdir"/usr/bin/2to3 "$pkgdir"/usr/bin/2to3-3.1
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ mv "$pkgdir"/usr/bin/2to3 "$pkgdir"/usr/bin/2to3-3.3
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -51,4 +52,6 @@ tests() {
_mv_files
}
-md5sums="92e94b5b6652b96349d6362b8337811d Python-3.2.tar.bz2"
+md5sums="2e7533b4009ac4adae62a7797a442e7a Python-3.3.0.tar.xz"
+sha256sums="09994d2885a8ef61b4b2389527a9805a4a05e3e0f121dbc8e4222f9010f5bbd7 Python-3.3.0.tar.xz"
+sha512sums="36aacc516d7486c8123656171a9400e3881146464abaa56b8dd1c8e3d0c1c31e305529157eacf6e29e3dd0a065c7ff8452addd1d178578bf8db4c9f5c1b7380f Python-3.3.0.tar.xz"