summaryrefslogtreecommitdiffstats
path: root/testing/python3
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman@gmail.com>2011-02-03 19:02:49 -0500
committerKiyoshi Aman <kiyoshi.aman@gmail.com>2011-02-03 19:03:13 -0500
commitffcceb29f2bce09e10d381113cb62e4926ef4169 (patch)
tree8ada1845336ad973fff77ecf0e13d51a43eb13b0 /testing/python3
parent6d7cae2c75d6fadc1b600b162f643ee71171245e (diff)
downloadaports-ffcceb29f2bce09e10d381113cb62e4926ef4169.tar.bz2
aports-ffcceb29f2bce09e10d381113cb62e4926ef4169.tar.xz
testing/python3: new aport
Diffstat (limited to 'testing/python3')
-rw-r--r--testing/python3/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/python3/APKBUILD b/testing/python3/APKBUILD
new file mode 100644
index 000000000..fc13a83e8
--- /dev/null
+++ b/testing/python3/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=python3
+pkgver=3.1.3
+pkgrel=0
+pkgdesc="A high-level scripting language"
+url="http://www.python.org"
+arch="all"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc" #$pkgname-tests"
+depends=
+makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev
+ sqlite-dev libffi-dev tcl-dev"
+source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir/Python-$pkgver"
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --with-threads \
+ --with-system-ffi \
+ --enable-unicode=ucs4 \
+ --with-dbmliborder=ndbm \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/Python-$pkgver"
+ make -j1 DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+#_mv_files() {
+# local i
+# for i in "$@"; do
+# mkdir -p "$subpkgdir"/${i%/*}
+# mv -f "$pkgdir"/$i "$subpkgdir"/$i || return 1
+# done
+#}
+#
+#tests() {
+# pkgdesc="The test modules from the main python package"
+# cd "$pkgdir"
+# _mv_files $(find usr/lib -type d -name 'test*')
+#}
+
+md5sums="ad5e5f1c07e829321e0a015f8cafe245 Python-3.1.3.tar.bz2"