summaryrefslogtreecommitdiffstats
path: root/testing/qt5-qtwebkit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-10 13:39:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-10 14:39:28 +0000
commit0b881a325f137e22f128643a20a13b18b9833a76 (patch)
treec775271319fab26104a063016e78e4202b82d08a /testing/qt5-qtwebkit
parenta17115daadb6b1bb099670b5a23ac47407bd0515 (diff)
downloadaports-0b881a325f137e22f128643a20a13b18b9833a76.tar.bz2
aports-0b881a325f137e22f128643a20a13b18b9833a76.tar.xz
testing/qt5-webkit: new aport
Diffstat (limited to 'testing/qt5-qtwebkit')
-rw-r--r--testing/qt5-qtwebkit/APKBUILD80
-rw-r--r--testing/qt5-qtwebkit/bison3.patch38
-rw-r--r--testing/qt5-qtwebkit/fix-rpath.patch11
-rw-r--r--testing/qt5-qtwebkit/pic.patch11
4 files changed, 140 insertions, 0 deletions
diff --git a/testing/qt5-qtwebkit/APKBUILD b/testing/qt5-qtwebkit/APKBUILD
new file mode 100644
index 000000000..e84303ff5
--- /dev/null
+++ b/testing/qt5-qtwebkit/APKBUILD
@@ -0,0 +1,80 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=qt5-qtwebkit
+pkgver=5.1.1
+pkgrel=1
+pkgdesc="Qt5 - QtWebKit components"
+url="http://qt-project.org/"
+arch="all"
+license="LGPLv2 with exceptions or GPLv3 with exceptions"
+depends=""
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev gstreamer1-dev
+ gst-plugins-base1-dev libxslt-dev mesa-dev icu-dev libxext-dev
+ glib-dev libxcomposite-dev libxrender-dev
+ "
+makedepends="$depends_dev
+ bison
+ flex
+ fontconfig-dev
+ gperf
+ libjpeg-turbo-dev
+ libpng-dev
+ libwebp-dev
+ pcre-dev
+ ruby
+ sqlite-dev
+ zlib-dev
+ "
+install=""
+subpackages="$pkgname-dev"
+source="http://download.qt-project.org/official_releases/qt/5.1/$pkgver/submodules/qtwebkit-opensource-src-$pkgver.tar.xz
+ bison3.patch
+ pic.patch
+ fix-rpath.patch
+ "
+
+_builddir="$srcdir"/qtwebkit-opensource-src-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ # remove some bundled
+ mkdir Source/ThirdParty/orig
+ mv Source/ThirdParty/glu/ \
+ Source/ThirdParty/gtest/ \
+ Source/ThirdParty/gyp \
+ Source/ThirdParty/mt19937ar.c \
+ Source/ThirdParty/qunit/ \
+ Source/ThirdParty/orig/ \
+ || return 1
+}
+
+build() {
+ cd "$_builddir"
+ qmake && make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install INSTALL_ROOT="$pkgdir" || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+ # remove rpath
+# chrpath --delete "$pkgdir"/usr/lib/qt5/libexec/* || return 1
+ sed -i -e 's:-L/home[^ ]\+::g' "$pkgdir"/usr/lib/pkgconfig/*.pc
+}
+
+md5sums="70e956dafcee1969de53d4de7b4691ad qtwebkit-opensource-src-5.1.1.tar.xz
+6b162cd2bc104f0ae83ca039401be7bf bison3.patch
+676350288efff119bee8513d9d0b2047 pic.patch
+e86a2f40683cd0633cb35c56cfce16de fix-rpath.patch"
+sha256sums="d6ee1e9111b0996277a512ae71736a05faa7c0de6d69ac2978adce79c3116a24 qtwebkit-opensource-src-5.1.1.tar.xz
+774f685f14e5341a010dd41a30700b92c336e2500880c8e5024e92a2c42499f2 bison3.patch
+51c0e843c5c6453526ee51ed69f2d4a7959767621da321f1082985dfe9f001ef pic.patch
+340e1a9b89088683c782456a4ebbfff0d6a18e08832f56a6cc0ecd5baadc51e1 fix-rpath.patch"
+sha512sums="aa7e310f1319902131dab5705a5bb2c02252f0d3d6b288ab13478ae42d38664578c52708cf3fa504ffc0b1f9f161e5bbcc65bdf6a7028c043b992211986a5f64 qtwebkit-opensource-src-5.1.1.tar.xz
+daa7aa25caa2cc70f6227d01e4ffdf9374d2c418f2aa34072a430c2c891c1bc5d68c6911f61f24505d4b8e89e572b6405fbfa1cecd55f0c66baa7abc8d0893f1 bison3.patch
+9a62a5e7af91c44311b517608262f88b5bc607e75dc5878dd08b0a0872ec03fb7a566df0a41413f7e60beb1b9880e24f084b90c38ed50d4219ec2ad6af9bd62f pic.patch
+156db7c346db2bba15332f2e0ab13add1e8e71cf4c165ea1adcfdcf054c73590d28202699bce3a48a8a974081bd6b2bf1b04196014d47ee53a748a56063e2495 fix-rpath.patch"
diff --git a/testing/qt5-qtwebkit/bison3.patch b/testing/qt5-qtwebkit/bison3.patch
new file mode 100644
index 000000000..4070c88e8
--- /dev/null
+++ b/testing/qt5-qtwebkit/bison3.patch
@@ -0,0 +1,38 @@
+From 60ba8bd5b3575d0c7740571fbb4e681b21a49a82 Mon Sep 17 00:00:00 2001
+From: Allan Sandfeld Jensen <allan.jensen@digia.com>
+Date: Fri, 16 Aug 2013 18:27:07 +0200
+Subject: [PATCH] ANGLE doesn't build with bison 3.0
+
+https://bugs.webkit.org/show_bug.cgi?id=119798
+
+Reviewed by Antti Koivisto.
+
+Make glslang.y compatible with bison 3.0
+by using %lex-param to set YYLEX_PARAM.
+
+* src/compiler/glslang.y:
+
+git-svn-id: http://svn.webkit.org/repository/webkit/trunk@154109 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+
+Task-number: QTBUG-32913
+Change-Id: I15505d31f0588c4d558b73befdb9d2358e29c1a3
+Reviewed-by: Jocelyn Turcotte <jocelyn.turcotte@digia.com>
+---
+ Source/ThirdParty/ANGLE/src/compiler/glslang.y | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/Source/ThirdParty/ANGLE/src/compiler/glslang.y b/Source/ThirdParty/ANGLE/src/compiler/glslang.y
+index 3cad335..b41e95a 100644
+--- a/Source/ThirdParty/ANGLE/src/compiler/glslang.y
++++ b/Source/ThirdParty/ANGLE/src/compiler/glslang.y
+@@ -47,6 +47,7 @@ WHICH GENERATES THE GLSL ES PARSER (glslang_tab.cpp AND glslang_tab.h).
+ %expect 1 /* One shift reduce conflict because of if | else */
+ %pure-parser
+ %parse-param {TParseContext* context}
++%lex-param {YYLEX_PARAM}
+
+ %union {
+ struct {
+--
+1.7.1
+
diff --git a/testing/qt5-qtwebkit/fix-rpath.patch b/testing/qt5-qtwebkit/fix-rpath.patch
new file mode 100644
index 000000000..b032e90c4
--- /dev/null
+++ b/testing/qt5-qtwebkit/fix-rpath.patch
@@ -0,0 +1,11 @@
+--- ./Tools/qmake/mkspecs/features/unix/default_post.prf.orig 2013-10-10 13:50:38.663745911 +0000
++++ ./Tools/qmake/mkspecs/features/unix/default_post.prf 2013-10-10 13:50:53.253909607 +0000
+@@ -32,8 +32,6 @@
+ QMAKE_OBJECTIVE_CFLAGS += -Wno-c++11-extensions -Wno-c++0x-extensions
+ }
+
+-contains(TEMPLATE, app): CONFIG += rpath
+-
+ isEqual(QT_ARCH,i386):CONFIG(debug, debug|release) {
+ # Make ld not cache the symbol tables of input files in memory to avoid memory exhaustion during the linking phase.
+ config_gnuld: QMAKE_LFLAGS += -Wl,--no-keep-memory
diff --git a/testing/qt5-qtwebkit/pic.patch b/testing/qt5-qtwebkit/pic.patch
new file mode 100644
index 000000000..ef8993ee3
--- /dev/null
+++ b/testing/qt5-qtwebkit/pic.patch
@@ -0,0 +1,11 @@
+--- ./Source/WTF/wtf/InlineASM.h.orig 2013-10-07 11:36:58.995128674 +0000
++++ ./Source/WTF/wtf/InlineASM.h 2013-10-07 11:37:28.058792290 +0000
+@@ -42,7 +42,7 @@
+ #define THUMB_FUNC_PARAM(name)
+ #endif
+
+-#if (OS(LINUX) || OS(FREEBSD)) && CPU(X86_64)
++#if (OS(LINUX) || OS(FREEBSD)) && (CPU(X86_64) || defined(__PIC__))
+ #define GLOBAL_REFERENCE(name) #name "@plt"
+ #elif CPU(X86) && COMPILER(MINGW)
+ #define GLOBAL_REFERENCE(name) "@" #name "@4"