summaryrefslogtreecommitdiffstats
path: root/testing/raptor
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-29 09:45:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-29 09:45:28 +0000
commitd6307bcbd20dee390965009f32c5c4b605fc12ab (patch)
tree291b69866c03fa599458175f816dc3a0d7d643ed /testing/raptor
parent470fc123d6aac94a0c477d78f005bfa65baf2183 (diff)
downloadaports-d6307bcbd20dee390965009f32c5c4b605fc12ab.tar.bz2
aports-d6307bcbd20dee390965009f32c5c4b605fc12ab.tar.xz
testing/raptor: remove *.la, buildfix for curl
Diffstat (limited to 'testing/raptor')
-rw-r--r--testing/raptor/APKBUILD11
-rw-r--r--testing/raptor/raptor-curl.patch12
2 files changed, 19 insertions, 4 deletions
diff --git a/testing/raptor/APKBUILD b/testing/raptor/APKBUILD
index 271012451..4f2451c67 100644
--- a/testing/raptor/APKBUILD
+++ b/testing/raptor/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=raptor
pkgver=1.4.21
-pkgrel=0
+pkgrel=1
pkgdesc="RDF parsing/storage backend"
url="http://www.librdf.org/"
arch="all"
@@ -12,7 +12,8 @@ depends_dev="curl-dev libxml2-dev libxslt-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://download.librdf.org/source/raptor-$pkgver.tar.gz"
+source="http://download.librdf.org/source/raptor-$pkgver.tar.gz
+ raptor-curl.patch"
_builddir="$srcdir"/raptor-$pkgver
prepare() {
@@ -39,6 +40,8 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la
}
-md5sums="992061488af7a9e2d933df6b694bb876 raptor-1.4.21.tar.gz"
+md5sums="992061488af7a9e2d933df6b694bb876 raptor-1.4.21.tar.gz
+ab48372dcd90a599fb0da73a10830d79 raptor-curl.patch"
diff --git a/testing/raptor/raptor-curl.patch b/testing/raptor/raptor-curl.patch
new file mode 100644
index 000000000..e47a496c4
--- /dev/null
+++ b/testing/raptor/raptor-curl.patch
@@ -0,0 +1,12 @@
+diff --git a/src/raptor_internal.h b/src/raptor_internal.h
+index f7944db..d9c2068 100644
+--- a/src/raptor_internal.h
++++ b/src/raptor_internal.h
+@@ -852,7 +852,6 @@ int raptor_utf8_is_nfc(const unsigned char *input, size_t length);
+
+ #ifdef RAPTOR_WWW_LIBCURL
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #endif
+