summaryrefslogtreecommitdiffstats
path: root/testing/redis
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-06 15:33:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:15 +0000
commit32ffc6930a85dd51cd492277553f484acdba27ba (patch)
treef99b0c6ee0ecc6e1cac70c41965b0836d51462c9 /testing/redis
parentafdaeb151fb51d71bb4b7f2103479a059889dc0a (diff)
downloadaports-32ffc6930a85dd51cd492277553f484acdba27ba.tar.bz2
aports-32ffc6930a85dd51cd492277553f484acdba27ba.tar.xz
testing/redis: patch to unbundle jemalloc
Diffstat (limited to 'testing/redis')
-rw-r--r--testing/redis/redis-unbundle-jemalloc.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/testing/redis/redis-unbundle-jemalloc.patch b/testing/redis/redis-unbundle-jemalloc.patch
new file mode 100644
index 000000000..9213f5d63
--- /dev/null
+++ b/testing/redis/redis-unbundle-jemalloc.patch
@@ -0,0 +1,14 @@
+--- src/redis-2.6.16/src/Makefile
++++ src/redis-2.6.16/src/Makefile.new
+@@ -71,9 +71,8 @@
+ endif
+
+ ifeq ($(MALLOC),jemalloc)
+- DEPENDENCY_TARGETS+= jemalloc
+- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
++ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
++ FINAL_LIBS+= -ljemalloc -ldl
+ endif
+
+ REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)