summaryrefslogtreecommitdiffstats
path: root/testing/ruby-rack-protection
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-06-11 15:24:13 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2013-06-11 15:24:13 +0000
commitd837043364dcf130692efd62a225e791074079be (patch)
tree62017e95dcede1f540b35a2cdbbd873c65809d30 /testing/ruby-rack-protection
parent5f4d18010f51ce131c9b19b4fbecd85ca1a89429 (diff)
downloadaports-d837043364dcf130692efd62a225e791074079be.tar.bz2
aports-d837043364dcf130692efd62a225e791074079be.tar.xz
testing/ruby-rack-protection: new aport
Diffstat (limited to 'testing/ruby-rack-protection')
-rw-r--r--testing/ruby-rack-protection/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/ruby-rack-protection/APKBUILD b/testing/ruby-rack-protection/APKBUILD
new file mode 100644
index 000000000..bad72342c
--- /dev/null
+++ b/testing/ruby-rack-protection/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_gemname=rack-protection
+pkgname=ruby-$_gemname
+pkgver=1.5.0
+pkgrel=0
+pkgdesc="Protections against typical web attacks"
+url="https://rubygems.org/gems/sinatra"
+arch="noarch"
+license="GPL"
+depends="ruby ruby-rack"
+depends_dev=
+makedepends="$depends_dev ruby-gems"
+install=""
+subpackages=""
+source="http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem"
+
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ return 0
+}
+
+package() {
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ local _geminstdir=$_gemdir/gems/$_gemname-$pkgver
+ mkdir -p "$pkgdir" || return 1
+
+ gem install --local --install-dir "$pkgdir"/$_gemdir \
+ --ignore-dependencies --verbose --no-rdoc --no-ri \
+ "$srcdir"/$_gemname-$pkgver.gem || return 1
+ rm -rf "$pkgdir"/$_gemdir/cache \
+ "$pkgdir"/$_geminstdir/ext \
+ "$pkgdir"/$_geminstdir/.require_paths
+}
+
+md5sums="bfbf7ac051bb0af8329c8ac65f296c67 rack-protection-1.5.0.gem"
+sha256sums="92d005f3ed62b3241e8b4b738fd6cd8c8ad6fdba0a230d9ecf37dd2adc319583 rack-protection-1.5.0.gem"
+sha512sums="1fe7026d20d63b144b73e8f4a4eed7b6dc042856fda0b4fedcc87f3232eb413439358349b6242acbd9cd7d23b2adc6b710c1e8762488cbd5d71e0ac2929c7695 rack-protection-1.5.0.gem"